Skocz do zawartości
embe2000

SSL - twoje połączenie nie jest w pełni bezpieczne

Rekomendowane odpowiedzi

Cześć, 
Pewnie to jakaś pierdoła, może ktoś mnie olśni :)

sklep www.sekrety.pl

zainstalowałem lets encrypt, hosting KEI, w chrome mam informację: Twoje połączenie z tą witryną nie jest w pełni bezpieczne. 

Co jest "nie tak"? SSL włączyłem w całym sklepie.

Z gory dzieki za pomoc

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jest tak, dlatego że poniższe zdjęcia ładowane są przez http:
 

Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/modules/ps_imageslider/images/sample-1.jpg'. This content should also be served over HTTPS.
(index):350 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/modules/ps_imageslider/images/sample-2.jpg'. This content should also be served over HTTPS.
(index):362 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/modules/ps_imageslider/images/sample-3.jpg'. This content should also be served over HTTPS.
(index):401 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/2-home_default/hummingbird-printed-t-shirt.jpg'. This content should also be served over HTTPS.
(index):475 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/21-home_default/brown-bear-printed-sweater.jpg'. This content should also be served over HTTPS.
(index):538 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/3-home_default/the-best-is-yet-to-come-framed-poster.jpg'. This content should also be served over HTTPS.
(index):595 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/4-home_default/the-adventure-begins-framed-poster.jpg'. This content should also be served over HTTPS.
(index):652 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/5-home_default/today-is-a-good-day-framed-poster.jpg'. This content should also be served over HTTPS.
(index):709 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/6-home_default/mug-the-best-is-yet-to-come.jpg'. This content should also be served over HTTPS.
(index):766 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/7-home_default/mug-the-adventure-begins.jpg'. This content should also be served over HTTPS.
(index):823 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/8-home_default/mug-today-is-a-good-day.jpg'. This content should also be served over HTTPS.
(index):877 Mixed Content: The page at 'https://sekrety.pl/' was loaded over HTTPS, but requested an insecure image 'http://sekrety.pl/modules/ps_banner/img/sale70.png'. This content should also be served over HTTPS.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W wypadku tych ilustracji, po aktywacji SSL adresy powinny automatycznie przełączyć się na https.
Tak jak napisał @ircykk wyczyść cache, również wygeneruj przyjazne URL.

Ogólnie jeśli to nie cache to źle zostały wprowadzone ustawienia.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Podobna zawartość

    • Przez skiracecenter
      Problem z SSL.   Wdrożyliśmy protokół SSL na stronie skiracecenter.pl.    Problem   protokół https nie wyświetla się na stronie głównej,  wyświetla się dopiero na podstronach, na które klikamy ze strony głównej, wyświetla się na wszystkich produktach, do których przechodzimy ze strony głównej lub ze stron kategorii. Jeśli klikamy na naszą stronę w wynikach wyszukiwania google, to wówczas lądujemy na stronie http. Jeśli wynikiem wyszukiwania jest strona produktu, to też nie ma ona protokołu https, tylko http, powoduje to błąd podczas dodawania do koszyka, który opisuję poniżej:  
      Konsekwencje problemu:
      Brak możliwości dodania produktu do koszyka na stronach z protokołem http (bez s) Jeśli klient znajdując się na stronie z adresem http (bez protokołu SSL) dodaje produkt do koszyka, wówczas wywala błąd: przykład: http://skiracecenter.pl/narty-damskie/1472-atomic-cloud-9-lithium-10-2018-ski-race-center-5900000218991.html Po kliknięciu "dodaj do koszyka" pojawia się błąd  Impossible to add the product to the cart.
      textStatus: 'error'
      errorThrown: ''
      responseText: https://skiracecenter.pl/narty-damskie/1472-atomic-cloud-9-lithium-10-2018-ski-race-center-5900000218991.html Po kliknięciu "dodaj do koszyka"  produkt prawidłowo dodaje się do koszyka: Istota problemu:
      Problem jest taki, że odnośniki z wyników wyszukiwania google odnoszą do stron http, a nie https, w związku z czym wszyscy nasi klienci, którzy nas znajdą w wynikach wyszukiwania google spadają na strony, z których praktycznie nie mogą dokonać zakupu do koszyka, gdyż ten działa tylko w na stronach w protokole SSL (HTTPS).  
      Pytania:
      Co zrobić, żeby
      Co zrobić, żeby wyniki wyszukiwania google kierowały na strony https? Co zrobić, żeby kliknięcie w koszyk ze strony z protokołem http nie powodowało błędu, tylko dodawało produkt do koszyka? Co zrobić, żeby mieć protokół https na wszystkich stronach?  
      Ustawienia programu:
      PRESTA: Włącz SSL  -----> TAK Aktywuj SLL dla wszystkich stron sklepu -----> TAK Podwyższone bezpieczeństwo sklepu ----->TAK Hosting:  LINUXPL
    • Przez zielony
      Witam,
      Proszę o pomoc w następującym temacie:
      Zainstalowałem certyfikat SSL po stronie serwera zgodnie z instrukcją usługodawcy: https://pomoc.hekko.pl/9,52,jak_dodac_certyfikat_ssl
      Po tym, kłódka nadal czerwona, chociaż z przedrostkiem https:// sklep się już otwierał - ok. Znalazłem w internecie informację, że trzeba jeszcze włączyć ssl po stronie presty w panelu sklepu. I tu pierwszy problem, nie mogę się zalogować do panelu admina. Nie pokazuje żadnych błędów tylko po prostu nadal wisi strona do wpisania loginu i hasła.
      Dodatkowo nie działają dość ważne funkcje w sklepie jak logowanie, zakładanie konta i wrzucanie do koszyka. A więc krótko mówiąc sklep nie działa.
      Trochę mnie martwi brak możliwości logowania do panelu sklepu.
      Pomyślałem, że wyłączę ssl po stronie serwera hekko. HTTPS przestało działać, ale niestety błędy jak poprzednio.
      Czy ktoś ma jakieś rady?
      Z góry dziękuję za pomoc.
    • Przez nikos111
      Witam , 
      Po instalacji SSL , mam problem z niektórymi obrazkami strony są ładowane bez https , Doczytałem się , że można to zrobić ręcznie w pliku Header.tpl . Tylko w którym (ych) plikach header.tpl należy zmienić ręcznie adresy ? Bo to raczej nie chodzi o ten ze ścieżki Themes > default-bootstrap . A może te obrazki (głównie logotypu przewoźników i operatorów płatności) przenieść  na serwer ?

       
    • Przez efrenzy
      Operator płatności elektronicznych PayU, informuje, że w dniu 16 stycznia 2015 roku PayU całkowicie zaprzestanie wspierania protokołu SSL 3.0. Jeżeli z niego Państwo korzystają, konieczne jest niezwłoczne dokonanie zmiany na bezpieczną wersję protokołu TLS w innym przypadku transakcje przestaną być realizowane.
       
      Warto sprawdzić:
      - czy serwery na, których stoją wasze sklepy nie są podatne,
      - czy po 16-stym stycznia nadal będą działać prawidłowo płatności
       
  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 666
    • Postów
      36 875
×