Skocz do zawartości
bonek04pl

Błd 500 przy potwierdzeniu zamówienia

Rekomendowane odpowiedzi

Witam serdecznie,

Nie znalazłem nigdzie rozwiązania dotyczącego mojego problemu (przeszukiwałem forum i internet ale tematy i rozwiązania związane z tym błędem nie pasowały do mojego problemu.

W załączniku wstawiam screen z logów PrestaShop

Sytuacja wygląda następująco:

Po przejściu przez proces zamówienia i wybraniu sposobu dostawy klient przy kliknięciu w potwierdzenie zamówienia dostaje błąd 500.

Różnica miedzy moim problemem a reszta problemów z HTTP 500 podczas potwierdzenia zamówienia jest taka że, już podczas przechodzenia przez proces zamówienia pojawiają się błędy typu:

  • część przewoźników z automatu dodaje darmowa wysyłkę mimo że w Backoffice wszystko ustawione jest jak trzeba
  • podczas edycji przewoźników, mimo tego że poprzednie zakresy wagi działały prawidłowo, teraz nie chcą się zatwierdzić (nawet po usunięciu i ponownym wprowadzeniu tego samego przewoźnika z tymi samymi parametrami,
  • nie działa realizacja zamówienia dla klienta w BackOffice,

Co zrobiłem do tej pory aby osunąć powyższy problem:

  • Przeinstalowałem moduły COD, Bankwire oraz ShipToPay
  • Przywracałem kopie zapasowe sklepu z przed kilku dni wstecz (baza SQL, pliki na serwerze),
  • Kontaktowałem się z usługodawca hostingu na którym umieszczona jest strona (wina nie leży po ich stronie)
  • Próbowałem dodać od nowa przewoźników z takimi samymi ustawieniami (bezskutecznie),
  • Sprawdziłem statusy zamówień - wszystko jest na swoim miejscu, żaden status nie został usunięty przypadkowo,
  • Nie aktualizowałem silnika sklepu - sklep nie był aktualizowany przez 1-Click-Upgrade (moduł niezainstalowany), automatyczna aktualizacja w panelu serwera wyłączona

Nie wiem co może być nie tak, jeszcze wczoraj klienci robili normalne zamówienia a w dniu dzisiejszym już nie.

Od około tygodnia nie były wprowadzone żadne zmiany - brak zmian w Backoffice, brak zmian w plikach na serwerze.

Prosiłbym o szybka pomoc.

Pozdrawiam serdecznie.

error500.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Zauważyłem coś jeszcze. Jeśli wpiszę wartość 30,25 w wyszukiwaniu produktów (pole cena podstawowa) to BackOffice wyrzuca mi błąd:

Złe zapytanie SQL
Something is wrong in your syntax obok '25 ORDER BY a.`id_product` ASC LIMIT 0, 50' w linii 14

I przez to muszę przywracać sklep z kopi zapasowej ponieważ po odświeżeniu strony błąd pozostaje.

Po wpisaniu 30.99 dostaje równiez błąd:

Złe zapytanie SQL
Something is wrong in your syntax obok '99 ORDER BY a.`id_product` ASC LIMIT 0, 50' w linii 14

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli po przywróceniu backupu dalej jest błąd znaczy to że istniał wcześniej lub baza jest uwalona.

Dziwny problem, jeśli nigdzie na necie się nie przewija musisz się zgłosić do kogoś żeby do zdebugował w sklepie, nie wygląda na jakiś problem z którymś z modułów czy modyfikacji.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7644
    • Postów
      36796
×