Skocz do zawartości
nikos111

Blocklayered - zmiana wyświetlanej nazwy bloku z KATALOG na FILTRY

Rekomendowane odpowiedzi

Chciałby zmienić nazwę, pod jaką wyświetla się blok filtrów nawigacyjnych. Od same początku wyświetla się jako KATALOG. O ile na kompach nie przeszkadza to specjalnie bo filtry od razu są widoczne w lewej kolumnie. Na komórkach niestety określenie KATALOG może pozostać niezauważone bądź nie powiązane z możliwością filtrowania produktów gdyż jest "zwinięty".  

Stąd pytanie - gdzie i jak można zamienić wyświetlaną nazwę KATALOG np. na FILTRY?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Zacząłem oczywiście od tłumaczeń, ale nie znalazłem tam wyrażenia KATALOG.

We wskazanej ścieżce znajduje się folder templates a w nim admin, front i hook. W każdym z tych folderów jest kilka plików z rozszerzeniem  .tpl ale w żadnym z nich nie znalazłem wyrażenia KATALOG.   

Jakiś pomysł co dalej?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Podobna zawartość

    • Przez kratek
      Witam, poszukuję modułu który będzie filtrował mi produkty na liście wyników w wyszukiwarce tak jak blocklayered (Blok filtrów nawigacyjnych). Czy istnieje taka możliwość w Prestashop?
       
      Niestety blocklayered działa tylko w obrębie kategorii
    • Przez kratek
      Witam!
      Na stronie kategori korzystam z modułu "Blok filtrów nawigacyunych". Są aktualnie 4 strony produktów jednak gdy skorzystam z opcji "Sortuj wg. ceny" - filtr ten nie uwzględnia mi produktów które są przecenione. Np: na pierwszej stronie wyników mam listę produktów (czapki) zaczynające się od 69zł brutto - natomiast na 3 stronie listy wyników znajdują się czapki które podlegają regule cenowej -30% i kosztują 59zł brutto (powinny być na początku). Czy spotkał się ktoś z was z takim problemem?
       
    • Przez cat11
      już nieaktualne - mój błąd w konfiguracji, wątek do usunięcia przepraszam za kłopot
    • Przez dwojod
      dziwne zachowanie zauważyłem przy tym module, bo przy pierwszym wybraniu jakiegoś filtra dodaje do parametru n wartość true co powoduje że strona nie filtruje poprawnie - dokładnie nie ma nic w <ul></ul> gdzie powinny być produkty
      po odświerzeniu strony filtr działa poprawnie
       
      spotkał się ktoś już z takim błędem? co mam badać żeby jakoś spróbować to naprawić
       
       
       
      modules/blocklayered/blocklayered-ajax.php?layered_category_79=79&id_category_layered=37&layered_price_slider=48_7460&orderby=date_add&orderway=desc&n=12true&_=1435319446951
    • Przez Wkar123
      Mam problem z modułem ?Blok filtrów nawigacyjnych? do Prestashop 1.6.0.14. Do tej pory moduł działał poprawnie, aż dzisiaj nie posłuchałem się komunikatu o aktualizacji modułu. Teraz mam wersję v2.0.9 i... filtrowanie nie dział.


      Moduł do filtrowania po atrybutach wyświetla się normalnie w lewej kolumnie tak jak wcześniej, ale kiedy wybieram konkretne atrybuty np. kolor i rozmiar to ich nazwa pojawia się w nagłówku kategorii oraz wskakują w belce filtrowania jako włączone filtry, ale po odświeżeniu ajaxa produkty się nie zmieniają i nie zostają odsiane przez filtrowanie.


      Włączałem i wyłączałem moduł, odbudowałem indeks cen oraz atrybutów, indekx URL, ale to nadal nie pomogło. Podejrzewam, że to jakiś błąd z url atrybutów, bo kiedy wybieram atrybut przez zaznaczenie checkboxa to w pasku adresów pojawia się on jako:


      http://adressklepu.pl/nazwakategorii#/kolor-czarny
       
      ale kiedy usunę # z nazwy kategorii to debugowanie pokazuje błąd:
       
      [Debug] This page has moved
      Please use the following URL instead: http://adressklepu.pl/nazwakategorii?selected_filters=kolor-czarny


      Po kliknięciu w link filtrowanie nadal nie działa, a jak odklikam wtedy zaznaczony checkbox z atrybutem i zaznaczę go jeszcze raz to url zmienia się na:
      http://adressklepu.pl/nazwakategorii?selected_filters=kolor-czarny#/kolor-czarny
       
      Nadal w działaniu filtrowania to nic nie zmienia, ale nie wiem czy tak powinno być.
       
      Jest coś czego jeszcze nie zrobiłem? Ma ktoś podobny problem i sobie z tym poradził? Jest jakiś sposób na downgrade modułu skoro przed aktualizacją działał poprawnie?
       
      Będę wdzięczny za każdą pomoc.
  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7617
    • Postów
      36706
×