Skocz do zawartości
datalux

PrestaShop 1.6.1.13 Problem ze zmianą domyślnego języka

Rekomendowane odpowiedzi

Używam PrestaShop w wersji 1.6.1.13. Chce usunąć wersję polską i ustawić wersje angielska jako domyslna na frontendzie .W panelu adminstracyjnym w "Menu -> Lokalizacja -> Lokalizacja -> Sekcja Configuration -> Default Language" ustawiłem na "angielski (Stany Zjednoczone)", "Set language from browser" na "No", "Default Country" na "Niemcy", "Set default country from browser language" na "No", "Default currency" na "Euro", w sekcji "Advanced" "Language identifier" na "en", "Country identifier" na "us". W "Menu -> Lokalizacja -> Języki" wyłączyłem język polski. Po wejściu na główną stronę frontendu wyświetla mi się "[Debug] This page has moved. Please use the following URL instead: http://nazwa_domeny/en" i nie ładuje się strona. Znalazłem kod w pliku "/classes/controller/FrontController.php" który jest odpowiedzialny za to:

if (defined('_PS_MODE_DEV_') && _PS_MODE_DEV_ && $_SERVER['REQUEST_URI'] != __PS_BASE_URI__) {
                die('[Debug] This page has moved<br />Please use the following URL instead: <a href="'.$final_url.'">'.$final_url.'</a>');
            }

Zmienna $_SERVER['REQUEST_URI'] zawiera wartość "/pl/", __PS_BASE_URI__ zawiera wartość "/" a _PS_MODE_DEV_ zawiera wartość "1". Stała _PS_MODE_DEV_ jest ustawiana w pliku "/config/config.inc.php":

define('__PS_BASE_URI__', $context->shop->getBaseURI());

Dlaczego nie ładuje się strona główna ? Dlaczego nie jest ładowany domyślnie język angielski ? Jak to naprawić ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się

Komentowanie zawartości tej strony możliwe jest po zalogowaniu



Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 776
    • Postów
      37 066
×