Skocz do zawartości

Rekomendowane odpowiedzi

Witam. Przeniosłem sklep z obecnego serwera na nowy wykupiony w nazwa.pl. Chciałem przetestować, czy strona będzie działała szybciej. Po skopiowaniu wszystkich plików i bazy danych "odpaliłem" i pojawił się następujący błąd:

 

Fatal error: Class 'Core_Business_ContainerBuilder' not found in /home/uzytkownik/ftp/moja_domena/config/bootstrap.php on line 27

 

Wiele razy przenosiłem sklep , ale pierwszy raz spotkałem się z takim komunikatem. Czyściłem cache, zmieniłem URL w bazie danych, ale w dalszym ciągu nie mogę uruchomić ani strony sklepu ani panelu administracyjnego. Będę wdzięczny za sugestie.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Komunikat jasno wskazuje

Nie znaleziono określonej  klasy w /home/uzytkownik/ftp/moja_domena/config/bootstrap.php

 

Więc podstawowe pytanie przy przeniosłeś także cały katalog Core ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

karlosek34 nie wiem co to za sklep, ale przemyśl czy przeniesienie na nazwa.pl to dobry pomysł.

Kiedyś mieliśmy tam jeden sklep i zbyt ciekawie to nie wygladało tzn. wolne ładowanie i przekraczanie zasobów.

Chyba, że przez te ostatnie lata się coś zmieniło.

Co do samego problemu spróbuj usunąć plik: cache/class_index.php

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Podobna zawartość

    • Przez apopo
      Postawiłem nową instalkę sklepu na Preście 1.6.1.18. Niby wszystko jest ok, ale jak próbuję ją przenieść na inną domenę na tym samym serwerze, wyskakują mi błędy.
      Przy wpisaniu adresu sklepu "500 Server Error", a przy próbie logowania się do panelu adm:
      [PrestaShopException]
      Link to database cannot be established:SQLSTATE[42000] [1044] Access denied for user 'xxxx_yyyy'@'localhost' to database 'zzz_aaa.pl'
      at line 102 in file classes/db/DbPDO.php
      97. public function connect() 98. { 99. try { 100. $this->link = $this->_getPDO($this->server, $this->user, $this->password, $this->database, 5); 101. } catch (PDOException $e) { 102. throw new PrestaShopException('Link to database cannot be established:'.$e->getMessage()); 103. } 104. 105. // UTF-8 support 106. if ($this->link->exec('SET NAMES \'utf8\'') === false) { 107. throw new PrestaShopException('PrestaShop Fatal error: no utf-8 support. Please check your server configuration.'); DbPDOCore->connect - [line 319 - classes/db/Db.php] DbCore->__construct - [line 240 - classes/db/Db.php] - [4 Arguments] DbCore::getInstance - [line 66 - config/alias.php] pSQL - [line 329 - classes/shop/Shop.php] - [1 Arguments] ShopCore::initialize - [line 114 - config/config.inc.php] require - [line 36 - admin/index.php] - [1 Arguments] Nie wiem co z tym powinienem zrobić. Proszę o pomoc.
       
  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7653
    • Postów
      36669
×