Skocz do zawartości
design4VIP

zmiana struktury meta title

Rekomendowane odpowiedzi

pozmienialem cala klase Meta.php - strony seo, cms, glowna, producenci, produkty.... dziala pieknie - jak nalezy. zonk robi z kategoriami... no za cholere nie chce odczytac mi zmian. niby ida te title przez cache, tego mam calkowicie wylaczonego, czyscilem juz z reki przez panel, przez ftpa i za cholere nie chce mi ruszyc ;/

 

co najsmiejsze, function getCategoryMetas() ma return Cache::retrieve($cache_id); i ok, stad wiem, ze idzie przez cache, i dump-ujac zmienna zwraca mi meta-title takie jak byc powinno: http://ilovesport.pl/478-girl-s-world a na pasku dalej co innego, po staremu ;/

 

ma ktos na to jakies lekarstwo bo mi sie pomysly skonczyly?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

może zapisz raz jeszcze nazwę kategorii ;)

nici :(

 

jak widac kateogria, jej seo zwraca meta tile poprawne ;/ a przegladarka tego nie widzi ;/

 

we wspomnianej funkcji przez samym 'return' mam:

var_dump(Cache::retrieve($cache_id)); czyli to co wywala zmienne w linku to to co powinna zwrocic meta dla kategorii, i te, jak widac w 'zwrocie' sa poprawne ;/ moze gdzie jeszcze jest jakies meta, mzoe w innym kontrolerze, moze cos przegapilem ;/ albo ten nieszczesny cache, moze tego w jakis inny jeszcze inny sposob poza czyszczeniem cache przegladarki, czyszczeniem cache presta, wylaczeniem cache w presta, czyszczeniem recznie z FTP.... sie zajac? no ja juz nie mam pomyslow ;/

 

 

EDIT.... jeszcze jedno co mi sie nasunelo.... tez zagadka jest to, ze np. produkt czy inne meta wywolujac dumpem ostatni return zwracaja zmienne pojedynczo, jedno zapytanie. a w kateogriach dwa razy dokladnie to samo (co widac w linku). o co w tym chodzi! ;/

 

EDIT 2...

no teraz to juz wrecz wkur..... delikatnie mowiac, zalamalem. zrobilem dokladna kopie sklepu. wrzucilem w override Meta.php z tymi samymi zmianami co na glownym sklepie.... dziala jak ta lala.... a na glownym dalej nie chce.

 

czy ktos cokolwiek z tego rozumie? o co w tym chodzi!!

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czyli to musi być cache skoro "kopia" sklepu zachowuje się poprawnie. W OVH miałem podobny "myk". Jak się już raz przeładowało tak trzeba było czekać - wymuszenie rewalidacji nic również nie dawało.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Czyli to musi być cache skoro "kopia" sklepu zachowuje się poprawnie. W OVH miałem podobny "myk". Jak się już raz przeładowało tak trzeba było czekać - wymuszenie rewalidacji nic również nie dawało.

no ok, tylko co przeladowalo i na co czekac.

 

jak psialem, wywalilem wszystkie mozliwe cache z poziomu FTP i normale i FSy. powylaczalem caly cache po stronie sklepu i nici. czyli na co czekac? 3 dni i nic sie nie zmienia....

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Musiałem poczekać, aż przeładowało "ich" cache. Nie chodzi o cache z poziomu FTP, itd. To wyglądało na jakiś serwer pośredniczący którym sobie przyśpieszali działanie stron. M.in. dlatego zmieniłem dostawcę usług.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

a ja czekam... czekam.... i nie zostaje mi  nic innego jak kombinowac dalej ;/

 

jeszcze jakies pomysly?

 

 

 

PS. bo jakos nie moge sie doszukac, nie pamietam czy wspominalem... serwer z nazwa.pl, wersja 1.6.0.14 ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Poradziłeś ?

 

Spotkałem się z tym problemem, musiałem cofnąć zmiany do zera w override, wyczyścić cache i wyłączyć wszystkie opcje pamięci podręcznej (polecam zwrócić uwagę aby przed wyłączeniem opcji globalnej pamięci podręcznej przestawić opcje dziedziczące też na stan wyłączony / czyszczenia ;) Dopiero po tym stopniowo dokładałem nowe nadpisane funkcje i obserwowałem czy się pojawiają zmiany na froncie.

 

Dodatkowo polecam zwrócić uwagę na: - warianty multistore językowe i ich zależności/priorytety - wyłączysz pamięć podręczną we Wszystkie Sklepy, a w języku Polskim będzie dalej trzymał i możesz nie wiedzieć dlaczego tak się dzieje.

 

To w zupełności pomogło rozwiązać ten temat, jak to mówią musi działać ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

to juz tez probowalem.... co najsmieszniejsze... przerzucilem na inny serwer i problem analogiczny. instalacja od poczatku, dorzucony tylko plik override i wszystko dziala tyko nie kateogrie. juz nie mam do tego sily i jak narazie porzucilem temat... mzoe z czasem sam sie rozwiaze ;) ja juz pomyslow nie mam

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A nie masz tam włączonego modułu do filtrowania dynamicznego listy produktów [Filtry nawigacyjne blok]? On jeszcze lubi nadpisać, robi globala na zmiennej smarty ;)

 

P.S. Sorry za opóźnienie w odpowiedzi, nie śledzę na bieżąco.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A nie masz tam włączonego modułu do filtrowania dynamicznego listy produktów [Filtry nawigacyjne blok]? On jeszcze lubi nadpisać, robi globala na zmiennej smarty ;)

 

P.S. Sorry za opóźnienie w odpowiedzi, nie śledzę na bieżąco.

moze to i jakis trop ;) mzoe dlatego na kopii mi chodzilo a na glownym nie, bo na kopii nie mialem BL-a :D (chyba). narazie porzucilem temat na rzecz reszty zmian, ale w wolnej chwili i to sprawdze... no, wkurze sie, jak to bedzie tak oczywista rzecz :D dzieki ;)

 

 

EDIT.

Sprawdzone. AAAAAAAA...... (czy na ksiezycu slychac moje darcie z wyrywania wlosow?) no przeciez to bylo oczywiste! oczywiscie, wylaczenie BL pomoglo i dziala jak nalezy ;/ no to teraz czyli, ze czas na zmiane meta w module i powinno smigac :D no tak, czlowiek szuka po cache, kompilacjach... przelecialem polowe kontrolerow, a jakos zapomnialem ,ze ten modul rzadzi sie swoimi prawami :D na najoczywistsze najtrudniej sie wpada :D jeszcze raz wielkie dzieki i poklony, @efrenzy.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

dla potomnych ;)

 

w blocklayered.php w sekcji od linii ~697 [dla BL v. 2.0.13] '// Generate meta title and meta description' jak mowi tytul jest ustalenie meta przez modul. wystarczy w tej sekcji dla potrzebnych elementow zmienic wpisy ;)

 

alez to bylo banalne :D az mi glupio :D

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się

Komentowanie zawartości tej strony możliwe jest po zalogowaniu



Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 770
    • Postów
      37 073
×