Skocz do zawartości
Wkar123

Błąd z modułem Blok filtrów nawigacyjnych po aktualizacji

Rekomendowane odpowiedzi

Mam problem z modułem ?Blok filtrów nawigacyjnych? do Prestashop 1.6.0.14. Do tej pory moduł działał poprawnie, aż dzisiaj nie posłuchałem się komunikatu o aktualizacji modułu. Teraz mam wersję v2.0.9 i... filtrowanie nie dział.


Moduł do filtrowania po atrybutach wyświetla się normalnie w lewej kolumnie tak jak wcześniej, ale kiedy wybieram konkretne atrybuty np. kolor i rozmiar to ich nazwa pojawia się w nagłówku kategorii oraz wskakują w belce filtrowania jako włączone filtry, ale po odświeżeniu ajaxa produkty się nie zmieniają i nie zostają odsiane przez filtrowanie.


Włączałem i wyłączałem moduł, odbudowałem indeks cen oraz atrybutów, indekx URL, ale to nadal nie pomogło. Podejrzewam, że to jakiś błąd z url atrybutów, bo kiedy wybieram atrybut przez zaznaczenie checkboxa to w pasku adresów pojawia się on jako:


http://adressklepu.pl/nazwakategorii#/kolor-czarny

 

ale kiedy usunę # z nazwy kategorii to debugowanie pokazuje błąd:

 

[Debug] This page has moved
Please use the following URL instead: http://adressklepu.pl/nazwakategorii?selected_filters=kolor-czarny



Po kliknięciu w link filtrowanie nadal nie działa, a jak odklikam wtedy zaznaczony checkbox z atrybutem i zaznaczę go jeszcze raz to url zmienia się na:

http://adressklepu.pl/nazwakategorii?selected_filters=kolor-czarny#/kolor-czarny

 

Nadal w działaniu filtrowania to nic nie zmienia, ale nie wiem czy tak powinno być.

 

Jest coś czego jeszcze nie zrobiłem? Ma ktoś podobny problem i sobie z tym poradził? Jest jakiś sposób na downgrade modułu skoro przed aktualizacją działał poprawnie?

 

Będę wdzięczny za każdą pomoc.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się

Komentowanie zawartości tej strony możliwe jest po zalogowaniu



Zaloguj się



  • Podobna zawartość

    • Przez marcincom
      Witam
      Mam Prestę 1.7.6.1 i próbowałem zainstalować moduł do aktualizacji i wywala mi taki błąd:
      "EROR" nie można install modułu autoupragde. Stworzenie menu "AdminSelfUpgrade" jest niemożliwe.
      Katalog w modułach "autoupgrade" jest utworzony i nie widzę tego w moim menu?

    • Przez nikos111
      Chciałbym spytać, czy - jeśli tak - to jak przenieść wyświetlanie bloku filtrów nawigacyjnych (blocklayered) z lewej kolumny do środkowej?
      Wiem, że ma to związek z hookami ale na tym się kończy moja wiedza.  
    • Przez nikos111
      Chciałby zmienić nazwę, pod jaką wyświetla się blok filtrów nawigacyjnych. Od same początku wyświetla się jako KATALOG. O ile na kompach nie przeszkadza to specjalnie bo filtry od razu są widoczne w lewej kolumnie. Na komórkach niestety określenie KATALOG może pozostać niezauważone bądź nie powiązane z możliwością filtrowania produktów gdyż jest "zwinięty".  
      Stąd pytanie - gdzie i jak można zamienić wyświetlaną nazwę KATALOG np. na FILTRY?
    • Przez kratek
      Witam, poszukuję modułu który będzie filtrował mi produkty na liście wyników w wyszukiwarce tak jak blocklayered (Blok filtrów nawigacyjnych). Czy istnieje taka możliwość w Prestashop?
       
      Niestety blocklayered działa tylko w obrębie kategorii
    • Przez kratek
      Witam!
      Na stronie kategori korzystam z modułu "Blok filtrów nawigacyunych". Są aktualnie 4 strony produktów jednak gdy skorzystam z opcji "Sortuj wg. ceny" - filtr ten nie uwzględnia mi produktów które są przecenione. Np: na pierwszej stronie wyników mam listę produktów (czapki) zaczynające się od 69zł brutto - natomiast na 3 stronie listy wyników znajdują się czapki które podlegają regule cenowej -30% i kosztują 59zł brutto (powinny być na początku). Czy spotkał się ktoś z was z takim problemem?
       
  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 784
    • Postów
      37 078
×