Skocz do zawartości
pt76

1.6.0.14 bez nadpisywania rozwala szablon

Rekomendowane odpowiedzi

Mam taki problem: zainstalowałem na serwerze (ecohost.pl) z Softaculous nową wersję Prestashop 1.6.0.14. Jednak po wyłączeniu nadpisywania w trybie debugowania rozjeżdża się cały szablon, chociaż sam sklep funkcjonalnie działa tak jak powinien.

 

Bez tego wyłączenia jeden z modułów (Ship to Pay) nie pracuje prawidłowo (pojawia się jednocześnie wybór - pobranie i przelew niezależnie od zaznaczonej opcji). Zastanawiam się czy to błąd w samym nowym Prestashop czy coś gryzie się z ustawieniami serwera? Już poustawiałem wszystko i skonfigurowałem, nie uśmiecha mi się jeszcze raz robić to samo. 

 

W wersji Presta poprzedniej 1.6.0.11 problem nie występował, instalowałem sklep i moduł kilka razy na tym samym serwerze, w taki sam sposób.

 

 

post-12619-0-50101600-1427826831_thumb.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

To normalne że przy wyłączonych nadpisywaniach część modułów może nie działać, ship2pay np.wymaga tego i z wyłączonym nadpisywaniem nie będzie nigdy działał.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

No tak, tylko jak włączę nadpisywanie to rozwala mi się szablon tak jak załączyłem, a że to szablon oryginalny Presta to nie wiem o co chodzi tym bardziej, że na razie nie mam innych modułów, modyfikacji.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Właśnie zobaczyłem w info konfiguracji że brak plików, załączam zrzut. Czyli instalator nowej wersji czegoś nie ładuje? 
Wiecie jak je uzupełnić, w którym folderze powinny być, gdzie je skopiować w FTP? No i czy te e z wersji 0.11 będą się nadawały?

post-12619-0-14171800-1427829415_thumb.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

nadpisywanie wylacza rowniej edycje modulow, tych zawartych w samym katalogu skorki. nie zapominajmy, ze sa rozne lokalizacje elementow modulow. glowne w katalogu ./modules a te wyswietlane (edytowane) w ./themes/skorka/modules ; ./css/modules ; ./js/modules

 

nawet podstawowa skorka ma wiele z moduliow zmienionych w samym szablonie i jezlei wylaczas to sie sypie, bo wysweitla oryginaly modulow.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Podmieniłem większość plików z działającej v .11 i dalej nie działa, ciągle to samo jak w pierwszym poście. Chyba się poddam i zainstaluję starszą wersję. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Przeinstalowałem jednak ten sklep na v.11 i wszystko działa ok, tzn działało póki nie zacząłem grzebać w Moduły/Pozycje bo chciałem pozbyć się środkowych podkategorii z miniaturkami, tymczasem coś odpiąłem i nie mam w lewej kolumnie ładnego rozwijanego menu kategorii, tylko jak w załączniku. Czy ktoś wie co usunąłem albo lepiej jak to podpiąć? Nie chciałem już zakładać nowego tematu.

post-12619-0-13154600-1427909973_thumb.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Szablon domyślny dobrze działa z domyślnymi modułami i pozycjami - jeśli jakieś usuwasz możesz mieć takie problemy. W moduły > pozycje możesz je poprzestawiać ale jeśli chcesz zmieniać układ to bez edycji html się nie obejdzie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

ok, czyli zepsułem, ale kolejny raz już nie będę reinstalował :) Proszę tylko o podpowiedź gdzie w html którym pliku mam wstawić <br><br> żeby opuścić trochę te komórki jak w załączniku, żeby to jakoś wyglądało. 

post-12619-0-91054800-1427915056_thumb.jpg

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 847
    • Postów
      37 175
×