Skocz do zawartości


Zdjęcie

Opis aktualizacji PrestaShop


  • Zamknięty Temat jest zamknięty
15 odpowiedzi w tym temacie

#1 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 04 marzec 2010 - 13:16

1. Aby zapisać tłumaczenie Back Office >> Tools >> Translations, wyeksportuj wszystkie języki. 2. Zrób kopię bazy danych. 3. Przez FTP, w katalogu PrestaShop (e.g., http://www.mysite.com/prestashop/), zrób kopie plików np: (e.g., http://www.mysite.com/prestashop_old/). 4. Pobierz najnowszą wersję Prestashop. 5. Rozpakuj na dysku. 6. Wrzuć pliki na serwer poprzez FTP (e.g., http://www.mysite.com/prestashop/). 7. Jeśli modyfikowałeś maile z katalogu /mails, przywróć je do głównego katalogu z wykonanej kopi. 8. Skopiuj zawartość katalogu /img z kopi do głównego katalogu /img. 9. Jeśli dodawałeś moduły również skopiuj je do katalogu /modules. 10. Skopiuj z kopi bezeceństwa plik settings.inc.php z /config do nowego folderu /config. 11. Uruchom z przeglądarki instalator (e.g., http://www.mysite.co...stashop/install). Po krótce opisane, w razie problemów pisz w dziale Aktualizacje. Pamiętaj o robieniu kopi bezpieczeństwa!

#2 bizon1975

bizon1975

    Zaawansowany

  • Members
  • PipPipPip
  • 401 postów

Napisano 23 marzec 2010 - 12:15

po zrobieniu aktualki tak jak pisze nadal mam w panelu wyswietlane ze jest dostepna 1.2.5 i na dole na pasku ze mam 1.2.2 no theme B&W nie dziala tak jak powinno

Bielizna Odzież Galanteria Damska i Męska [zakaz linkowania do stron zawierających materiały do dorosłych - ircykk]


#3 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 24 marzec 2010 - 22:05

Widać nie podmieniłeś wszystkich plików jak należy albo w cachu siedzi coś jeszcze.

#4 zeus23

zeus23

    Zaawansowany

  • Members
  • PipPipPip
  • 107 postów

Napisano 04 kwiecień 2010 - 00:09

wszystko dziala jak nalezy, dzieki za info

#5 adamus007p

adamus007p

    Początkujący

  • Members
  • Pip
  • 12 postów

Napisano 13 październik 2010 - 09:53

czyli tak naprawde trzeba zrobic1. kopie bezpieczenstwa (sklep, baza danych)2. wyslac na serwer nowy sklep3. do nowego sklepu przegrac tylko settings.inc.php i odpalic instalacja np. wybrac opcje update4. po skonczeniu dograc brakujace maile, zdjecia i modulybo mozna zrobic tak ze do folderu sklepwgrac zawartosc nowego sklepu i nadpiac wszystko i wlaczyc instalacje tylko czy jest sens? zawsze jakies smieci moga zostacdobrze napisalem?

#6 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 13 październik 2010 - 14:24

Jasne że można i tak.

#7 emils

emils

    Zaawansowany

  • Members
  • PipPipPip
  • 358 postów

Napisano 29 grudzień 2010 - 23:52

Zrobiłem takstworzyłem nową bazę danych. W katalogu public_html stworzyłem nowy folder i tam wrzuciłem nową prestę (1.3.5). Wszystko się zainstalowało, działa nawet fajnie. Jednak kiedy chcę powrócić na zwykłą stronę sklepu znika prawa strona. Wchodzę więc w PA, potem w moduły i... pusto.Cały PA jest dobrze, przywróciłem bazę danych, usunąłem ten folder z nowym sklepem, usunałem nową bazę danych i dalej to samo.Wyczyściłem ciasteczka, ale nie pomogło.Macie jakieś pomysły jak przywrócić moduły w PA?

#8 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 29 grudzień 2010 - 23:57

Jeden z modułów ma błędy. Włącz wyświetlanie błędów w configu.

#9 emils

emils

    Zaawansowany

  • Members
  • PipPipPip
  • 358 postów

Napisano 29 grudzień 2010 - 23:59

Ty to jesteś :PPrzypomniałem sobie jakie moduły były z prawej strony i zacząłem robić backupy i usuwać z serwera.Działo się to przez moduł koszyka.

#10 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 30 grudzień 2010 - 00:07

heh nom wytrwały jesteś tak sprawdzać po kolei :)

#11 emils

emils

    Zaawansowany

  • Members
  • PipPipPip
  • 358 postów

Napisano 30 grudzień 2010 - 00:11

To trzeci moduł, nie jest źle :PCiekawi mnie tylko dlaczego tak się stało. Wgrałem blok koszyka z nowej wersji.Po wgraniu z wersji obecnej wszystko gra. Tylko znów problem z usuwaniem produktów. Wina więc musi chyba leżeć po stronie presty...

#12 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 30 grudzień 2010 - 10:12

Może nie nadpisałeś modułów przy aktualizacji.

#13 emils

emils

    Zaawansowany

  • Members
  • PipPipPip
  • 358 postów

Napisano 30 grudzień 2010 - 10:34

Może nie nadpisałeś modułów przy aktualizacji.

Nie nie, chodzi mi o to, że wgranie modułu koszyka z innych wersji daje taki efekt. Jednak mam niby drugą domenę i tam wrzuciłem 1.3.5 a potem 1.4 i na obu wersjach koszyk działa. Szkoda, że 1.3.5 nie ma w 100% języka ojczystego, ale aktualizację zrobię.

#14 dszmaj

dszmaj

    Początkujący

  • Members
  • Pip
  • 1 postów

Napisano 22 styczeń 2014 - 06:20

Co może być problemem po aktualizacji skryptu do najnowszej wersji (za pomocą 1-click-upgrade)?

Wszystko działa, tylko karta produktu w ogóle się nie wyświetla.

http://herbacianeinspiracje.pl/

problematyczna karta: http://herbacianeins.../94-edgvdegvbsd

#15 PJ1988

PJ1988

    Początkujący

  • Members
  • Pip
  • 7 postów

Napisano 12 styczeń 2016 - 16:28

Witam wszystkich, proszę o pomoc, bo najlepiej jest liczyć na siebie.

 

obecnie posiadam 1.5.4.1 i chcę aktualizować pod 1.6.1.4.  

 

1-click-upgrade nie działa. Mój hostingodawca nie ma możliwości upgradowania do tej wersji. Należy zrobic to samemu - ale jak?

 

Jak chcę zainstalowac modul ww to po kliknięciu "instaluj" otwiera kartę z informacją (poniższy link do strony został przeze mnie celowo skrócony):

 

"

Błąd serwera
Wystąpił błąd podczas pobierania http://www.bankmonet...lfUpgrade przez witrynę. Zasób jest niedostępny z powodu przeprowadzanej konserwacji lub nieprawidłowej konfiguracji."
 
 
To samo okno pokazuje się jak klikam w zainstalowany już moduł w menu "zaawansowane".
 
Mam obecnie zrobiony backup z p.a, na serwerze i ściągnąłem wszystkie pliki przez ftp. Zależy mi na aktualizacji, by zostało wszystko co do tej pory udało mi się zrobić na sklepie, z możliwością poprawienia błędów, które będą widoczne po zaktualizowaniu P.S do 1.6.
 
Czy ktoś mi pomoże krok po kroku?
 
P.S Ważne, by sklep nadal działał pod domeną główną, nie pod www.domena./podfolder/.
 
 
Ogromne dzięki


#16 ircykk

ircykk

    Administrator

  • Administrators
  • 5031 postów
  • PrestaShop:1.5, 1.6

Napisano 12 styczeń 2016 - 18:45

Stare jak świat, jeśli masz problem z aktualizacją rozpocznij nowy wątek - ten zamykam.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

Hosting zapewnia: Hekko.pl