Skocz do zawartości
ircykk

[Moduł] ShipToPay (ship2pay) dla PrestaShop 1.6

Rekomendowane odpowiedzi

U mnie też jest problem na Preście 1.6.1.10 - zarówno wersja modułu 2.0 jak i najnowsza nie powoduje żadnych zmian w matrycy. Efekt jest taki, że wszystkie opcje płatności są dostępne dla każdej formy dostawy.

 

Na 1.6.1.9 jeszcze wszystko działa bezbłędnie i gładko.

 

Czy komuś udało się to już rozwiązać? Będę bardzo wdzięczny, ponieważ Klienci się mieszają w zamówieniach. Z góry dziękuję za wsparcie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Masz rację - działa dobrze. Przepraszam za fałszywy alarm.

 

Miałem ciekawy przypadek: na tym samym serwerze mam zarówno serwis produkcyjny jak i testowy (w subdomenie test.domena.pl). Praktycznie wszystko jest 1 do 1 odwzorowane:

- baza (dump z produkcji jest spięty z wersją testową)

- wersja Prestashop 1.6.1.10

- ustawienia konfiguracyjne

- szablon

- modyfikacje w szablonie

- lista modułów

 

Jedyne różnice to SSL oraz moduł, który koniecznie potrzebuje prawdziwą domenę (feed produktowy dla reklam Google).

 

Na test.domena.pl mam wyłączone nadpisywaniepost-14979-0-65729700-1481575538_thumb.jpg i co ciekawe tam ship2pay działa prawidłowo.

 

Kiedy włączyłem nadpisywanie w serwisie produkcyjnym - również zadziałało od kopa.

Moduł jest świetny - wielkie dzięki za jego stworzenie i utrzymywanie!

 

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam.

Mam dziwny problem z modułem.

Dwie formy płatności przelew i PayU :

 

DPD
-PayU (payu)
-Przelew na konto (bankwire)
DPD Krajowa za pobraniem (COD)
-nic
 
W kroku 5 pojawia się tylko:
- dla DPD tylko PayU
- dla DPD COD tylko przelew
Wiecie jak to naprawić aby w DPD pojawiało się jedno i drugie, a w DPD COD nic albo pobranie(lepiej nic bo nie znalazłem darmowego modułu by piasło poprostu pobranie nie potrzebuje naliczania żadnych opłat)?
 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W ustawieniach modułu szhi2pay przypisujesz dla sposobów dostawy odpowiednie sposoby płatności.

 

Jeżeli nie przypiszesz żadnego sposobu płatności - czyli twoje NIC - to klient nie złoży zamówienia

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Hej!

 

Do tej pory rozwiązanie z usunięciem pliku override/classes/PaymentModule.php i cache/class_index.php u mnie rozwiązywało problem lecz od wczoraj przestało działać. Po zrealizowaniu płatności poprzez przelewy24 zamówienie nie pojawia się w systemie, nie jest widoczne dla klienta jak i w panelu.

 

Ustawiania z Wydajności:

Kompilacja szablonu NIGDY

Pamięć podręczna NIE

Wyłącz moduły nie od PrestaShop NIE

Wyłącz wszystkie nadpisywania NIE

Wsztstkie FUNKCJONALNOŚĆ CCC NIE

Algorytm: Użyj biblioteki...

Użyj pamięci podręcznej: NIE

 

Problem pojawił się kiedy włączyłem pamięć podręczną oraz funkcjonalności CCC, ponieważ chciałem poprawiać wydajność strony.  Przywrócenie ostawień do wyżej wymienionych już nie pomogło.

 

Dodam, że próbują naprawić:

-przeinstalowałem obie wtyczki: przelewy24, ship2pay

-usunąłem jeszcze raz PaymentModule.php i class_index.php.

 

Zauważyłem, że plik cache/class_index.php powstaje na nowo przy każdy przeładowaniu strony, czy to może być powodem?

 

Bardzo proszę o pomoc.

 

Prestashop 1.6.1.7

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

pytanie bardzo zasadnicze

 

ale to, że

 

"Po zrealizowaniu płatności poprzez przelewy24 zamówienie nie pojawia się w systemie, nie jest widoczne dla klienta jak i w panelu."

 

nie ma nic wspólnego z modułem ship2pay - szukaj problemu w module przelewy24

 

"Zauważyłem, że plik cache/class_index.php powstaje na nowo przy każdy przeładowaniu strony, czy to może być powodem?"

 

nie to jest prawidłowe zachowanie - class_index.php jest to plik z "listą używanych klas" która mówi silnikowi sklepu z których klas ma używać

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

(...)

 

Po zrealizowaniu płatności poprzez przelewy24 zamówienie nie pojawia się w systemie, nie jest widoczne dla klienta jak i w panelu.

 

(..)

A czy ślad po tych zamówieniach pojawia się jako niezrealizowane koszyki Klientów?

No i czy pieniądze są możliwe do ręcznego zaksięgowania w panelu Przelewy24?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A czy ślad po tych zamówieniach pojawia się jako niezrealizowane koszyki Klientów?

No i czy pieniądze są możliwe do ręcznego zaksięgowania w panelu Przelewy24?

 

Brak koszyków o takie wartości jak zamówienia, więc raczej nie ma śladu.

 

W panelu przelewy24 wszystkie problematyczne zamówienia mają status "Do wykorzystania". Wcześniejsze zamówienia, z którymi nie było problemu mają zawsze status "Dokonana" .

 

Zgłosiłem problem do przelewów24 ale póki co też nie wiedzą co może być przyczyną.

 

Problem wydaję mi się powiązany z  ship2pay, ponieważ to samo działo się zaraz po zainstalowaniu ship2pay i dopiero usunięcie plików PaymentModule.php i class_index.php go rozwiązało. Teraz usunięcie tych plików nic nie daje a plik class_index.php wraca przy każdym przeładowaniu strony. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ostatnio jeden z moich klientów miał podobny problem otóż testował przelewy24 i zamówienie nie pojawiało sie w panelu, jak sie okazało testował moduł przy wyłączonym sklepie więc może i tu jest podobnie?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pytanie do admina, mam również problem z przelewy24 w kompilacji z przedstawionym modułem. Nie widać w backoffice przyjętych zamówień ze zrealizowanych płątności przelewy24....  prosiłbym o pomoc w powyższym problemie

 

w zakładce zamówienia brak przyjętych zamóień do realizacji, dodatkowo w momencie chęci manualnego dodania zamówienia z poziomu admina występuje błąd http 500 error

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Pytanie do admina, mam również problem z przelewy24 w kompilacji z przedstawionym modułem. Nie widać w backoffice przyjętych zamówień ze zrealizowanych płątności przelewy24....  prosiłbym o pomoc w powyższym problemie

 

w zakładce zamówienia brak przyjętych zamóień do realizacji, dodatkowo w momencie chęci manualnego dodania zamówienia z poziomu admina występuje błąd http 500 error

 

Ale tak z ciekawości - co ma moduł ship2pay wspólnego z w/w problemami?

 

Moduł ship2pay służy wyłącznie do powiązania sposobów płatności ze sposobami wysyłki - i nie ma absolutnie żadnego wpływu na działanie modułów płatności. Jego działanie kończy się w chwili gdy klient wybierze sposób płatności........... resumując twoje problemy nie są związane z tym modułem!!!!!!

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ale tak z ciekawości - co ma moduł ship2pay wspólnego z w/w problemami?

 

Moduł ship2pay służy wyłącznie do powiązania sposobów płatności ze sposobami wysyłki - i nie ma absolutnie żadnego wpływu na działanie modułów płatności. Jego działanie kończy się w chwili gdy klient wybierze sposób płatności........... resumując twoje problemy nie są związane z tym modułem!!!!!!

Niestety nie jest możliwe aby problem leżał po stronie e-sklepu ponieważ do momentu zainstalowania dodatku ship2pay  płatności przelewy24 działały bezproblemowo. Po otrzymaniu płatności przez przelewy24 zamówienia nie widać w bazie w backoffice. W przypadku wyboru płatności zwykłym przelewem lub za pobraniem jest w porządku. Może ma ktoś radę na powyższy problem.... ?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Niestety nie jest możliwe aby problem leżał po stronie e-sklepu ponieważ do momentu zainstalowania dodatku ship2pay  płatności przelewy24 działały bezproblemowo. Po otrzymaniu płatności przez przelewy24 zamówienia nie widać w bazie w backoffice. W przypadku wyboru płatności zwykłym przelewem lub za pobraniem jest w porządku. Może ma ktoś radę na powyższy problem.... ?

 

To jeżeli jest tak jak twierdzisz - to odinstaluj moduł ship2pay i sprawdź  co się dzieje bez tego modułu.

 

Ja raczej skłaniał bym się ku temu że jest uwalony moduł przelewy24 ........................... nie wiem, którą wersję tego modułu masz bo tak się składa, iż część z modułów przelewy24 dziwnie działała i tworzyła zamówienia w sklepie po powrocie do sklepu tzn po zapłaceniu przez klienta i w przypadku gdy pojawia się jakiś błąd w module zamówienie w sklepie nie jest tworzone.........ale skoro pozostałe moduły płatności działają  to raczej nie obwiniał bym ship2pay .................. natomiast co do błędu 500 to tu już na 100% ship2pay nie ma wpływu ........... no ale mogę się mylić.

 

Sugerował bym włączyć wyświetlanie błędów w sklepie i przetestować............................ i był bym daleki od twierdzenia że "Niestety nie jest możliwe aby problem leżał po stronie e-sklepu" - tak szczerze to po mimo tego, że od lat zajmuję się wdrożeniami sklepów na preście (m.innymi) to tak śmiałej tezy nie nie śmiał bym wysunąć ;)

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

sugeruję w takim razie zlecić to komuś ........... albo samemu spróbować rozwiązac problem

ja zaczął bym od  włączenia wyświetlania błędów w preście ............... lub zerknij do logów błędów presty znajdujących się w katalogu /log i logów błędów serwera

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się

Komentowanie zawartości tej strony możliwe jest po zalogowaniu



Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 785
    • Postów
      37 079
×