Skocz do zawartości


Zdjęcie

Link do podanej strony przy liscie produktu !!!!


  • Zaloguj się, aby dodać odpowiedź
8 odpowiedzi w tym temacie

#1 mick

mick

    Początkujący

  • Members
  • Pip
  • 13 postów

Napisano 29 sierpień 2014 - 14:42

Witam serdecznie,
Mam problem z oprogramowanie PrestaShop.
Chodzi o to, że zrobiłem wszystko dokładnie jak jest napisane w poniższym linku : http://michak.pl/sta...tashop-czesc-1/ działa mi beż zarzutu.
W momencie kiedy wpiszę w inputa tekst to pojawia się na liście produktów przy danym produkcie. Mój problem polega na tym, że chcę, aby był tam link do jakieś strony. Kiedy wpiszę adres strony to dalej widzi jako tekst, a chcę, aby przenosiło mnie na wpisaną stronę.

Jeśli ktoś może mi pomóc to bardzo proszę o pomoc
Pozdrawiam



#2 ircykk

ircykk

    Administrator

  • Administrators
  • 4997 postów
  • PrestaShop:1.5, 1.6

Napisano 29 sierpień 2014 - 17:26

Proszę popraw tytuł aby dokładnie wyjaśniał problem.



#3 Mistrz Yoda

Mistrz Yoda

    Ekspert

  • Members
  • PipPipPipPip
  • 1439 postów
  • LocationOstrołęka
  • PrestaShop:1.2, 1.4

Napisano 29 sierpień 2014 - 18:33

Link klikalny tak wygląda:

<a href="http://domena.rozszerzenie">Anchor</a>

Więc by link był klikalny tpl musi zawierać taki kod:

<a href="{$product->sap|default:''}">{$product->sap|default:''}</a>

 (Na przykładzie zmiennych z tutoriala z post #1)


Uwaga: Rady tego użyszkodnika mogą być niebezpieczne dla Twojego komputera, względnie doprowadzić mogą do zwapnienia poszycia nośnika dysku twardego lub preizolowanych połączeń magistrali głównej w wyniku procesów iniekcji kodu SQL H2O.

#4 mick

mick

    Początkujący

  • Members
  • Pip
  • 13 postów

Napisano 01 wrzesień 2014 - 08:06

Link klikalny tak wygląda:

<a href="http://domena.rozszerzenie">Anchor</a>

Więc by link był klikalny tpl musi zawierać taki kod:

<a href="{$product->sap|default:''}">{$product->sap|default:''}</a>

 (Na przykładzie zmiennych z tutoriala z post #1)

 

 

Okej, ale zmienia mi to na link w tpl, a nie zmienia mi na liście produktów.

A mi chodzi o to, żeby link był aktywny na liśie produktów.

I jak to wogole zrobić ??? :/



#5 mick

mick

    Początkujący

  • Members
  • Pip
  • 13 postów

Napisano 01 wrzesień 2014 - 11:29

Okej, ale zmienia mi to na link w tpl, a nie zmienia mi na liście produktów.

A mi chodzi o to, żeby link był aktywny na liśie produktów.

I jak to wogole zrobić ??? :/

 

Dokładnie chodzi mi o ten link zaznaczony na zdjęciu, żeby był aktywny.

Z góry wielkie dzięki

 

Untitled-1.jpg



#6 Mistrz Yoda

Mistrz Yoda

    Ekspert

  • Members
  • PipPipPipPip
  • 1439 postów
  • LocationOstrołęka
  • PrestaShop:1.2, 1.4

Napisano 01 wrzesień 2014 - 12:41

Przychodzi baba do lekarza i lekarz się jej pyta:

- Co Pani jest?

- Kupcowa - odpowiada baba.

- Nie pytam kim Pani jest tylko co Pani jest?

- Mnie się zrobił wrzut Panie doktorze!

- Gdzie?

- W Otwocku!

 

No, a tak na poważnie, to w post #5 dowiadujemy się, że chodzi o Back Office a wieszczę, że w post # 7 dowiemy się która wersja PS.


Uwaga: Rady tego użyszkodnika mogą być niebezpieczne dla Twojego komputera, względnie doprowadzić mogą do zwapnienia poszycia nośnika dysku twardego lub preizolowanych połączeń magistrali głównej w wyniku procesów iniekcji kodu SQL H2O.

#7 mick

mick

    Początkujący

  • Members
  • Pip
  • 13 postów

Napisano 01 wrzesień 2014 - 13:01

Hehe :-) dobre :-)

A wersja PS to 1.6



#8 mick

mick

    Początkujący

  • Members
  • Pip
  • 13 postów

Napisano 02 wrzesień 2014 - 07:22

To jak pomoże ktoś ??? Prztnajmniej niech ktoś powie w jakim pliku można to zrobić  :-(



#9 sower

sower

    Guru

  • Moderatorzy
  • 4208 postów
  • Location3miasto
  • PrestaShop:1.2, 1.3, 1.4, 1.5, 1.6

Napisano 11 wrzesień 2014 - 20:50

no ale @yoda  napisał ci co trzeba zrobić


468x60.jpg

468x60_pl.gif

 

QUICK PRESTA SUPPORT:  gg 45116037
SKLEPY  MODUŁY INTEGRACJE  POMOC TECHNICZNA





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

Hosting zapewnia: Hekko.pl