Skocz do zawartości


Zdjęcie

Problem z przyjznymi URL


  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 eloy

eloy

    Początkujący

  • Members
  • Pip
  • 12 postów

Napisano 26 styczeń 2013 - 12:06

Witam serdecznie! Mam takie pytanko , ponieważ nazwy produktów mam przetłumaczone w języku obcym gdzie występują znaki (odpowiedniki polskich ż , ó ź itp.) , i teraz takie pytanko ponieważ generuje mi przyjazny url automatycznie z tymi znakami i jak się tego pozbyć lub co zrobić aby automatycznie generowało przyjazne URL bez tych znaków (oczywiście poza metodą ręczną:) ) Generalnie chodzi o to że jak np. dodaje produkt i w nazwie są polskie znaki (óżź) to przyjazny URL generuje się z tymi znakami automatycznie i nie zamienia na (ozz). Jak sobie z tym poradzić ? Bedę wdzięczny za pomoc Pozdrawiam

#2 eloy

eloy

    Początkujący

  • Members
  • Pip
  • 12 postów

Napisano 26 styczeń 2013 - 14:46

W pewien sposób sobie poradziłem tylko nie wiem czy to nie odbije się na czymś innym :) Mianowicie Podmieniłem plik admin.js Z wersji 1.5.2 na 1.5.3.1 i teraz jak dodaje produkty to juz mi automatycznie zmienia przyjazne linki ale tych starych mi nie pozmieniało wiec chyba recznie bede sie bawił :( Pytanie czy taka podmiana moze negatywnie na cos wpłynąc ? Kolejna sprawa ma ktos pomysl jak te juz istniejace przyjazne linki pozmieniac z automatu ? Pozdrawiam

#3 ircykk

ircykk

    Administrator

  • Administrators
  • 5057 postów
  • PrestaShop:1.5, 1.6

Napisano 15 luty 2013 - 23:33

Raczej nie powinno zaszkodzić ale lepiej przeklej samą funkcję. Co do istniejących produktów to jedynie jakiś skrypt w php.

#4 karlosek34

karlosek34

    Początkujący

  • Members
  • Pip
  • 4 postów

Napisano 16 sierpień 2016 - 20:28

Witajcie. U mnie jest podobny kłopot jeśli w nazwie pliku występuje polski znak, np.:

 

http://xxx.pl/img/łokieć.jpg

 

Mimo, iż plik jest na serwerze, to zdjęcie nie wyświetli się. Jeśli usuniemy polskie znaki, problem zniknie. Niestety mam sytuację, w której zmiana nazwy pliku odpada, bo jest on już użyty w szablonie. Czy można to gdzieś ustawić?



#5 karlosek34

karlosek34

    Początkujący

  • Members
  • Pip
  • 4 postów

Napisano 16 sierpień 2016 - 21:21

Witam. Mam podobny problem z polskimi znakami w nazwie pliku, np.:

 

http://xxx.pl/allegro/xxx/łokcie.jpg

 

Jeśli w nazwie pliku /jpg występuje polski znak, to w przeglądarce wyświetli się znak zapytania. Tak, jakby nie było zdjęcia na serwerze, a jest. Czy można to gdzieś ustawić?

 


#6 sower

sower

    Guru

  • Moderatorzy
  • 4241 postów
  • Location3miasto
  • PrestaShop:1.2, 1.3, 1.4, 1.5, 1.6

Napisano 16 sierpień 2016 - 21:49

ta w konfiguracji serwera ewentualnie


468x60.jpg

468x60_pl.gif

 

QUICK PRESTA SUPPORT:  gg 45116037
SKLEPY  MODUŁY INTEGRACJE  POMOC TECHNICZNA





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

Hosting zapewnia: Hekko.pl