Skocz do zawartości


Zdjęcie

[MODUŁ] Ship to Pay (ship2pay) dla PrestaShop 1.5x


  • Zaloguj się, aby dodać odpowiedź
62 odpowiedzi w tym temacie

#41 elvispl

elvispl

    Początkujący

  • Members
  • Pip
  • 2 postów

Napisano 23 październik 2013 - 12:50

Witam,
Natomiast przy wyborze "płatność przy odbiorze" pokazuje mi taki brzydki duży kwadrat ze znakiem zapytania.
Wie ktoś jak to zmienić ?
Przy wyborze płatność przelewem jest fajna ikonka z drukiem przelewu.


Jeśli nie działa na PS 1.5.5 to odinstaluj i usuń moduł. Następnie pobierz z w/w strony i zainstaluj od nowa.

Aby usunąć kwadrat ze znakiem zapytania:
modules/cashondelivery/views/templates/hook/payment.tpl

<span class="syntaxdefault"></span><span class="syntaxkeyword"><</span><span class="syntaxdefault">p class</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"payment_module"</span><span class="syntaxkeyword">>
</span><span class="syntaxdefault">    </span><span class="syntaxkeyword"><</span><span class="syntaxdefault">a href</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"{$link->getModuleLink('cashondelivery', 'validation', [], true)|escape:'html'}"</span><span class="syntaxdefault"> title</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"{l s='Pay with cash on delivery (COD)' mod='cashondelivery'}"</span><span class="syntaxdefault"> rel</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"nofollow"</span><span class="syntaxkeyword">>
<!--</span><span class="syntaxdefault">        </span><span class="syntaxkeyword"><</span><span class="syntaxdefault">img src</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"{$this_path_cod}cashondelivery.gif"</span><span class="syntaxdefault"> alt</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"{l s='Pay with cash on delivery (COD)' mod='cashondelivery'}"</span><span class="syntaxdefault"> style</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"float:left;"</span><span class="syntaxdefault"> </span><span class="syntaxkeyword">/></span><span class="syntaxdefault"> </span><span class="syntaxkeyword">-->
</span><span class="syntaxdefault">        </span><span class="syntaxkeyword"><</span><span class="syntaxdefault">br </span><span class="syntaxkeyword">/>{</span><span class="syntaxdefault">l s</span><span class="syntaxkeyword">=</span><span class="syntaxstring">'Pay with cash on delivery (COD)'</span><span class="syntaxdefault"> mod</span><span class="syntaxkeyword">=</span><span class="syntaxstring">'cashondelivery'</span><span class="syntaxkeyword">}
</span><span class="syntaxdefault">        </span><span class="syntaxkeyword"><</span><span class="syntaxdefault">br </span><span class="syntaxkeyword">/>{</span><span class="syntaxdefault">l s</span><span class="syntaxkeyword">=</span><span class="syntaxstring">'You pay for the merchandise upon delivery'</span><span class="syntaxdefault"> mod</span><span class="syntaxkeyword">=</span><span class="syntaxstring">'cashondelivery'</span><span class="syntaxkeyword">}
</span><span class="syntaxdefault">        </span><span class="syntaxkeyword"><</span><span class="syntaxdefault">br style</span><span class="syntaxkeyword">=</span><span class="syntaxstring">"clear:both;"</span><span class="syntaxdefault"> </span><span class="syntaxkeyword">/>
</span><span class="syntaxdefault">    </span><span class="syntaxkeyword"></</span><span class="syntaxdefault">a</span><span class="syntaxkeyword">>
</</span><span class="syntaxdefault">p</span><span class="syntaxkeyword">></span><span class="syntaxdefault"> </span>


#42 d4b

d4b

    Zaawansowany

  • Members
  • PipPipPip
  • 248 postów
  • LocationPoznań
  • PrestaShop:1.5, 1.6

Napisano 28 październik 2013 - 13:03

Zamiast ukrywać obrazek lepiej sprawić aby się pojawiał :)
cashondelivery.php

 		$this->context->smarty->assign(array(
 			'this_path' => $this->_path,
+			'this_path_cod' => $this->_path,
 			'this_path_ssl' => Tools::getShopDomainSsl(true, true).__PS_BASE_URI__.'modules/'.$this->name.'/'
 		));
 		return $this->display(__FILE__, 'payment.tpl');

Remember to brush your teeth! Tworzenie sklepów w rozsądnej cenie oraz unikalne teksty na stronę www najtaniej w mieście.


#43 Mikell

Mikell

    Początkujący

  • Members
  • Pip
  • 11 postów

Napisano 01 luty 2014 - 22:45

Witam, mam problem z tym modułem w wersji 1.5.6.2. Moduł w wersji 1.02. Po instalacji i wybraniu konfiguracji modułu wyświetla błąd. Moduł nie jest poprawnie zainstalowany! Przenieś plik /beta/modules/shiptopay/Hook.php do /beta/override/classes/ . Plik skopiowałem tak jak jest napisane, ale z folderu /beta/modules/shiptopay/ nie można usunąć tego pliku. I tak jest w dwóch lokalizacjach, ale znika ten komunikat da się zaznaczyć wybrane płatności i dopisać do nich dostawców. Druga sprawa to podczas wyboru na końcu zamówienia (Płatność przy odbiorze) nie przechodzi dalej i jest biała strona, ale zamówienie tak jakby przechodzi, bo jest panelu administratora i w zakładce historia zakupów klienta. Dla płatności przelewem działa. Miał może ktoś podobny problem, jak to naprawić ?

#44 lukas4ws

lukas4ws

    Początkujący

  • Members
  • Pip
  • 2 postów

Napisano 10 luty 2014 - 20:10

witam, Też mam taki sam problem na wersji 1.5.6.2 że po złożeniu zamówienia przez klienta i wybraniu płatność przy odbiorze nie ma potwierdzenia zamówienia tylko wyświetlana jest biała strona albo tylko napis "display" na białym tle, ale zamówienie tak jakby przechodzi, bo jest w panelu administratora i w zakładce historia zakupów klienta. Dla płatności przelewem działa poprawnie. Ma może ktoś pomysł jak podejść do tego?

#45 lukas4ws

lukas4ws

    Początkujący

  • Members
  • Pip
  • 2 postów

Napisano 10 luty 2014 - 21:53

rozwiązanie problemu: u mnie pomogło podmienienie pliku \modules\cashondelivery\controllers\front\validation.php z wersji 1.5.6.1 powodzenia!

#46 carla222

carla222

    Początkujący

  • Members
  • Pip
  • 1 postów

Napisano 23 luty 2014 - 14:20

OK, już działa... moduł pojawił się w kategorii Administracja.
Wygląda na to, że wszystko śmiga :D :D :D


Witam,

Mam wersję PrestaShop 1.5.6.2. po instalacji modułu ship2pay wersja 1.5 ze strony http://addonspresta....hip-to-pay.html pojawia się komunikat - pomyślnie pobrano moduł jednak nie mogę odnaleźć go w liście zainstalowanych wtyczek. Proszę o pomoc.
Może ktoś poleci coś funkcjonalnego dla wersji 1.5.6.2 co pozwoliłoby włączyć funkcje identyczne jak z modułu ship2pay?

#47 chomiczek

chomiczek

    Początkujący

  • Members
  • Pip
  • 1 postów

Napisano 24 luty 2014 - 09:53

Ja niestety też mam problem z tym modułem w wersji 1.5.6.2. Po przeniesieniu pliku Hook.php do katalogu override/classes/ moduł niby działa, w sensie, że mogę ustawiać gdzie ma być jaka metoda płatności, Załączony plik  s2p001.jpg   38,44 KB   50 Ilość pobrań ale podczas zamówienia i tak mam widoczne obie opcje (tutaj wybrana metoda płatności Kurier - przedpłata) Załączony plik  s2p002.jpg   22,14 KB   50 Ilość pobrań jakiś pomysł?

#48 sower

sower

    Guru

  • Moderatorzy
  • 4241 postów
  • Location3miasto
  • PrestaShop:1.2, 1.3, 1.4, 1.5, 1.6

Napisano 24 luty 2014 - 10:35

jakiś pomysł?


zacznij może od usunięcia "zkeszowanego" indeksu klas
czyli cache/class_index.php

468x60.jpg

468x60_pl.gif

 

QUICK PRESTA SUPPORT:  gg 45116037
SKLEPY  MODUŁY INTEGRACJE  POMOC TECHNICZNA


#49 lukruk

lukruk

    Użytkownik

  • Members
  • PipPip
  • 44 postów

Napisano 03 kwiecień 2014 - 18:29

Jest już może wersja dla 1.6.x ?

#50 luthien

luthien

    Użytkownik

  • Members
  • PipPip
  • 40 postów

Napisano 29 maj 2014 - 06:41

Jest już może wersja dla 1.6.x ?

Teoretycznie nie, a praktycznie to działa pod 1.6 wersja z 1.5 ;)



#51 Kilpo

Kilpo

    Początkujący

  • Members
  • Pip
  • 6 postów

Napisano 30 czerwiec 2014 - 09:47

Mam zauktualizowaną prestę do 1.6.0.8 i Ship2Pay przestał działać. Zainstalowałem ponownie Ship2Pay v1.0.1. Widoczne w PA mogę robić ustawienia, lecz nie działa tak, jakie miał przeznaczenie. Jednym słowem teraz wyskakują zawsze metody płatności.

 

a praktycznie to działa pod 1.6 wersja z 1.5

 

Jak kolega to uczynił ???? Proszę o pomoc.



#52 powershop24.pl

powershop24.pl

    Zaawansowany

  • Members
  • PipPipPip
  • 120 postów
  • LocationSzczecin
  • PrestaShop:1.4, 1.6

Napisano 30 czerwiec 2014 - 10:35

Mam zauktualizowaną prestę do 1.6.0.8 i Ship2Pay przestał działać. Zainstalowałem ponownie Ship2Pay v1.0.1. Widoczne w PA mogę robić ustawienia, lecz nie działa tak, jakie miał przeznaczenie. Jednym słowem teraz wyskakują zawsze metody płatności.

 

Jak kolega to uczynił ???? Proszę o pomoc.

Póki co nie działa pod 1.6.0.8.

Tu więcej na ten temat:

http://prestadesign....e-2?hl=ship2pay

 

K.


Sklep internetowy http://www.powershop24.pl - baterie, akumulatorki, ładowarki, latarki, pojemniki do przechowywania baterii i akumulatorków amerykańskiej firmy Powerpax.

#53 Kilpo

Kilpo

    Początkujący

  • Members
  • Pip
  • 6 postów

Napisano 30 czerwiec 2014 - 10:55

B.dziękuję.



#54 luthien

luthien

    Użytkownik

  • Members
  • PipPip
  • 40 postów

Napisano 01 lipiec 2014 - 18:45

Działający moduł pod prestą 1.6.0.8

http://www.prestasho...r-ps-15-and-16/



#55 tomekmo

tomekmo

    Użytkownik

  • Members
  • PipPip
  • 66 postów

Napisano 05 kwiecień 2016 - 09:51

Czy u Was też nie działa ship2pay przy zaznaczonej wysyłce darmowej lub gdy wstawię 0 zł za wysyłkę?



#56 scifi

scifi

    Początkujący

  • Members
  • Pip
  • 3 postów

Napisano 13 marzec 2017 - 12:04

A ja mam taki problem

Presta 1.6.1.11 - Cash on delivery (COD) v1.3 oraz Ship to Pay v2.0 

podczas zamawiania mogę wybrać sposób dostawy - wybieram przelew jest ok pojawiają sie opcje które chciałem, lecz kiedy wybiorę za pobraniem - pojawia się faktycznie - odbierz przesyłkę za pobraniem ale pozostałe metody przelewem dalej są nie znikają - jak to zrobić ??

- metoda zamawiania na 1 stronie

 

PS kasowałem czyli cache/class_index.php 

Pomocy :)??!!



#57 ircykk

ircykk

    Administrator

  • Administrators
  • 5065 postów
  • PrestaShop:1.5, 1.6

Napisano 13 marzec 2017 - 14:17

Przeczytaj jeszcze raz tytuł tego tematu.



#58 onken

onken

    Początkujący

  • Members
  • Pip
  • 5 postów

Napisano 07 kwiecień 2017 - 14:33

Ktoś pomoze ??

 

Chciałem wrzucuc przelewy24, konto juz aktywne i zonk, nie można wybrać przelewy24....

 

Prestashop 1.5.4 i shiptopay.1.02

 

I taki problem....

 

presta.jpg



#59 ircykk

ircykk

    Administrator

  • Administrators
  • 5065 postów
  • PrestaShop:1.5, 1.6

Napisano 07 kwiecień 2017 - 15:32

Sprawdź na domyślnym szablonie.



#60 onken

onken

    Początkujący

  • Members
  • Pip
  • 5 postów

Napisano 07 kwiecień 2017 - 15:53

Hmm

 

Sprawdziłem, na oryginalnym szablonie da sie wejsc w przelewy24

 

Nie ma wyboru w kropkach ale da sie kliknąć.

 

To jak teraz dopasowac ten nieszczesny szablon :) ?? ( bo chyba nie ma znaczenia szerokosc fotki, i napisu - to chyba nie ma znaczenia ? ) ( bo moze "przykrywa" kropkę wyboru )

 

Tak mi przyszło do głowy...






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych

Hosting zapewnia: Hekko.pl