Skocz do zawartości
KacperP

problem przy aktualizacji 1.3.1.1 ma 1.4.4.1

Rekomendowane odpowiedzi

Mam taki błąd przy 3 etapie i nie wiem co mam w tym zrobić a muszę aktualizować sklep do 20 jak macie jakieś pomysły pomocyError during install/upgrade:You may have to: Fix the error(s) displayed Put your database backup Modify the file settings.inc.php to put the old version for the line with _PS_VERSION_ Restart the upgrade process from the beginingPozdrawiam,KP

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wyświetla się tylko to:

One or more errors have occurred, you can find more informations below or in the log/installation.log file.Error during install/upgrade:You may have to: Fix the error(s) displayed Put your database backup Modify the file settings.inc.php to put the old version for the line with _PS_VERSION_ Restart the upgrade process from the begining

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie przepraszam usunąłem go i teraz mam coś takiego

*ERROR* 2011/12/08 - 18:25:33: PHP error: /* PHP:add_module_to_hook(blockmyaccount, header); */*ERROR* 2011/12/08 - 18:25:33:

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

W tym pliku jednak jest kopiuje część kodu:

*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_order_detail` ADD `reduction_percent` DECIMAL(10, 2) NOT NULL AFTER `product_price`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'reduction_percent'*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_order_detail` ADD `reduction_amount` DECIMAL(20, 6) NOT NULL AFTER `reduction_percent`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'reduction_amount'*ERROR* 2011/12/08 - 18:36:36: SQL query: INSERT INTO `ps_configuration` (`name`, `value`, `date_add`, `date_upd`) VALUES('PS_1_3_2_UPDATE_DATE', NOW(), NOW(), NOW())*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzone wyst?pienie 'PS_1_3_2_UPDATE_DATE' dla klucza 2*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_zone` DROP `enabled`*ERROR* 2011/12/08 - 18:36:36: SQL error: Nie mo?na wykona? operacji DROP 'enabled'. Sprawd?, czy to pole/klucz istnieje*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_order_detail` ADD `group_reduction` DECIMAL(10, 2) NOT NULL AFTER `reduction_amount`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'group_reduction'*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_order_detail` ADD `ecotax_tax_rate` DECIMAL(5, 3) NOT NULL AFTER `ecotax`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'ecotax_tax_rate'*ERROR* 2011/12/08 - 18:36:36: SQL query: INSERT INTO `ps_configuration` (`name`, `value`, `date_add`, `date_upd`) SELECT 'PS_LOCALE_LANGUAGE', l.`iso_code`, NOW(), NOW() FROM `ps_configuration` c INNER JOIN `ps_lang` l ON (l.`id_lang` = c.`value`) WHERE c.`name` = 'PS_LANG_DEFAULT'*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzone wyst?pienie 'PS_LOCALE_LANGUAGE' dla klucza 2*ERROR* 2011/12/08 - 18:36:36: SQL query: INSERT INTO `ps_configuration` (`name`, `value`, `date_add`, `date_upd`) SELECT 'PS_LOCALE_COUNTRY', co.`iso_code`, NOW(), NOW() FROM `ps_configuration` c INNER JOIN `ps_country` co ON (co.`id_country` = c.`value`) WHERE c.`name` = 'PS_COUNTRY_DEFAULT'*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzone wyst?pienie 'PS_LOCALE_COUNTRY' dla klucza 2*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_employee` ADD `bo_color` varchar(32) default NULL AFTER `stats_date_to`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'bo_color'*ERROR* 2011/12/08 - 18:36:36: SQL query: ALTER TABLE `ps_employee` ADD `bo_theme` varchar(32) default NULL AFTER `bo_color`*ERROR* 2011/12/08 - 18:36:36: SQL error: Powtórzona nazwa kolumny 'bo_theme'

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

no właśnie nie na ogicom.comBoje się że przekombinowałem z mysql tabelami ale postawiałem go na nowo usunąłem nową bazę i wgrałem starastrona chodzi ale troszeczkę się rozsypała skórka

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Wczoraj zrobiłem test na local na mac-u i prwado podobnie przez przypadek powiązałem 2 bazy bo mac ma możliwosć zdalnej pracy online i wszystkie tabele się zastąpiły i z tego możliwe ze jest ten cały bałagan .teraz np już nie wiem czy tworzyć od nowa i zastępować nowe na stare.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

czyścisz bazę z tabel - wgrywasz backup bazy na ftp wrzucasz pliki z 1.3 - oczywiście z backupu który przed przystąpieniem do upgrade zrobiłeś (a zrobiłeś prawda?)i musi chodzić

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

zrobiłem spoko moim błędem była za duża pewność co do swoich tabel (za bardzo się pośpieszyłem)dziś wieczorem tak zrobię. dzięki wielkie za pomoc i z aktualizacje zrobię po ludzku i nie będę wydziwiał :Dsorki za problem pozdrawiam,KP

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam,Ogólnie wszystko jest ok powróciłem do starej wersji ale mam problem z klientami bazy są skopiowane ale nie działają ich hasła. Wiecie w czym jest problem? Czy jest jakieś rozwiązanie z tej sytuacji? z góry dziękuje za pomoc,pozdrawiam,KP

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Witam,Ogólnie wszystko jest ok powróciłem do starej wersji ale mam problem z klientami bazy są skopiowane ale nie działają ich hasła. Wiecie w czym jest problem? Czy jest jakieś rozwiązanie z tej sytuacji? z góry dziękuje za pomoc,pozdrawiam,KP

COOKIE_KEY w configu musi się zgadzać ze starym sklepem by hasła działały.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się



  • Przeglądający

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

  • Aktywni użytkownicy

    Nikt jeszcze nie otrzymał reputacji w tym tygodniu.

  • Statystyki forum

    • Tematów
      7 793
    • Postów
      37 112
×