Skocz do zawartości

apopo

Members
  • Zawartość

    10
  • Rejestracja

  • Ostatnia wizyta

Zawartość dodana przez apopo

  1. Witam, od jakiegoś czasu mam spore problemy techniczne ze sklepem (apopo pl), dlatego postawiłem nową instalkę na innej domenie i chciałbym do niej przenieść produkty, klientów i zamówienia), a następnie przeinstalować takiego gotowca na starą domenę. Z przerzuceniem sklepu sobie poradzę ale potrzebuję pomocy z przeniesieniem baz. Chcę mieć pewność, że będzie to zrobione dobrze, dlatego wchodzi w grę usługa płatna (kontakt w stopce sklepu). Obydwie instalki są na wersji 1.6.1.18 Sprawa jest pilna. Pzdrawiam Mirek
  2. Przeniesienie sklepu na inną domenę

    SSL już działa. Chyba potrzebował trochę czasu, żeby się "dostroić" Pozostał jeszcze problem z zamówieniami, które nie działają w jednym oknie, ale to jest jakiś problem z bazą a nie wynika on z przeprowadzki, czyli raczej temat na inny post. Zauważyłem też, że jakiś skrypt włącza mi automatycznie mod_security na serwerze. Wyłączam go, a po 20 minutach okazuje się, że znowu jest włączony i dzieje sie tak tylko na tej jednej domenie.
  3. Postawiłem nową instalkę sklepu na Preście 1.6.1.18. Niby wszystko jest ok, ale jak próbuję ją przenieść na inną domenę na tym samym serwerze, wyskakują mi błędy. Przy wpisaniu adresu sklepu "500 Server Error", a przy próbie logowania się do panelu adm: [PrestaShopException] Link to database cannot be established:SQLSTATE[42000] [1044] Access denied for user 'xxxx_yyyy'@'localhost' to database 'zzz_aaa.pl' at line 102 in file classes/db/DbPDO.php 97. public function connect() 98. { 99. try { 100. $this->link = $this->_getPDO($this->server, $this->user, $this->password, $this->database, 5); 101. } catch (PDOException $e) { 102. throw new PrestaShopException('Link to database cannot be established:'.$e->getMessage()); 103. } 104. 105. // UTF-8 support 106. if ($this->link->exec('SET NAMES \'utf8\'') === false) { 107. throw new PrestaShopException('PrestaShop Fatal error: no utf-8 support. Please check your server configuration.'); DbPDOCore->connect - [line 319 - classes/db/Db.php] DbCore->__construct - [line 240 - classes/db/Db.php] - [4 Arguments] DbCore::getInstance - [line 66 - config/alias.php] pSQL - [line 329 - classes/shop/Shop.php] - [1 Arguments] ShopCore::initialize - [line 114 - config/config.inc.php] require - [line 36 - admin/index.php] - [1 Arguments] Nie wiem co z tym powinienem zrobić. Proszę o pomoc.
  4. Przeniesienie sklepu na inną domenę

    Niestety, po przeniesieniu instalki na domenę docelową nie działa certyfikat SSL i nie wiem o co chodzi. W panelu sklepu nie jest aktywny guzik "Włącz protokół SSL na wszystkich stronach", a po wciśnieciu linku "Kliknij tutaj, aby sprawdzić czy twój sklep obsługuje HTTPS" wyskakuje błąd "404 Not Found The resource requested could not be found on this server!". SSL jest skonfigurowany na sewerze i działał przed reinstalacją sklepu i nie wiem o czym zapomniałem.
  5. Przeniesienie sklepu na inną domenę

    Chyba z grubsza ogarnąłem temat, przynajmniej w podstawowym zakresie. Wczoraj, po mojej kolejnej interwencji w hostingu, nagle wieczorem, jak za dotknięciem czarodziejskiej różczki, przenoszenie sklepów i baz zaczęło działać, a błędy już się nie pokazują. Dodam, że przenosiłem dokładnie te same pliki i te same bazy, w ten sam sposób. Podejrzewam, że coś było nie tak z ustawieniami na serwerze, ale nie chcą się do tego przyznać Postawiłem nową instalkę i podczepilem bazę i produkty ze starego sklepu. Pozostał mi tylko problem z zamówieniami. Nie działają zamówienia w jednym oknie (działają tylko w 5 krokach). Dzieje się tak z powodu jakiegoś błędu w bazie, z którym nie mogę sobie poradzić (przed podpięciem bazy problem nie występuje). Niestety, na moim komputerze zachowały się tylko takie, uszkodzone bazy oraz bazy stare (hosting zgubił wszystkie kopie baz i plików). Na razie wybrałem koncepcję z bazą uszkodzoną lecz nowszą. Za chwilę będę wszystko przeinstalowywał. napiszę czy wszystko poszło tak jakbym chciał. Nie wiem jeszcze co zrobić z tym problemem przy zamówieniach i co zrobić z bazą która jest bardzo zaśmiecona, ale na razie o tym nie myślę. Najważniejsze, żeby udało się w ogóle uruchomić cokolwiek. W tym miejscu chciałbym serdecznie podziękować Tobie sower za pomoc. Jeżeli widziałbyś jakąś możliwość rozwiązania problemów, o których napisałem w tym poście, to chętnie skontaktuję się z Tobą na priva. Pozdrawiam
  6. Przeniesienie sklepu na inną domenę

    Zaczynam podejrzewać, że hosting coś namieszał z ustawieniami i nieprawidłowo zaciaga się na serwer skompresowany plik bazy danych .gz. Wieczorem przetestuję jeszcze czy pomaga przerzucenie tabel bezpośrednio na serwerze.
  7. Przeniesienie sklepu na inną domenę

    sower, chętnie zrobię Ci dostęp, i będę Cię całował po rękach jak mi pomożesz. Ja już jestem bezsilny, wyczerpałem wszystkie pomysły. Wersje na 100% są takie same. Przenoszę wszystko 1:1, zarówno pliki, jak i bazę. Próbowałem już przenosić pliki przez FTP, próbowałem też na serwerze z kopii. W celu upewnienia się, że instalka nie jest walnięta, zainstalowałem i skonfigurowałem od zera nowy sklep na innej domenie. Po przeniesieniu wystepują te same problemy. Na logikę wygląda to na jakieś problemy z ustawieniami na serwerze albo z samą Prestą 1.6.1.18 (z wcześniejszymi wersjami nigdy nie miałem tego typu problemów). Dajcie znać czy ktoś przenosil tę wersję i jaki był efekt. Przed chwilą wysmarowałem maila do hostingu, zobaczymy co odpowiedzą. Sprawa jest tym badziej dla mnie bolesna, że podobne problemy wystepują w moim sklepie głównym. Chciałem sprawdzić, czy uda mi sie skonfigurować sklep na innej domenie i przywrócić go na domenę główną, a tu taka niespodzianka.
  8. Przeniesienie sklepu na inną domenę

    Masz rację sower. Wydawało mi się, że wszystko zostało poprawnie wprowadzone, przejrzałem jednak ponownie pliki i tabele i okazało się, że miałem literówkę w linku do bazy. Po poprawieniu mam jednak kolejne problemy. Sklep całkiem się posypał. Panel logowania wygląda tak: Po zalogowaniu, mniej więcej tak samo wygląda cały panel administracyjny. Są też problemy po stronie klienta. Niektóre funkcje nie działają, a po włączeniu trybu debugowania i kliknięciu np na koszyk wyskakuje komunikat: To trochę za dużo, jak dla mnie. Boję się, że coś spie_rzę.
  9. Witam, od kilku dni mam problem z wysyłaniem wiadomości ze sklepu, klienci nie otrzymują powiadomień Podczas próby wysłanai wiadomości testowej sklep twierdzi, że jest błąd konfiguracji, a podczas próby wysłania wiadomości do klienta pojawia się błąd: "Swift Mailer was not found. Please download Swift Mailer 5.4.x at https://github.com/swiftmailer/swiftmailer/releases and copy swift_required.php file with all other files to public_html/tools/swift5/ directory retaining the directory structure. Niestety wgranie tego katalogu na serwer nie pomaga (nic się nie zmienia). Dodam, że w katalogu tools jest podkatalog swift, a w nim plik swift_required.php. Hosting twierdzi, że ustawienia poczty w sklepie są prawidłowe a problem leży po stronie sklepu, który z jakiegoś powodu blokuje wysyłkę poczty. Presta 1.6.1.18 Problem wystepuje zarówno przy ustawieniu mail PHP, jak i przy SMTP. Proszę o pomoc.
  10. Nie mam, ale rzeczywiście chyba instalowałem ten moduł (swiftmailer-5.4.1), żeby sprawdzić co to jest, i odinstalowałem. Może zostawił jakieś śmieci.
×