Skocz do zawartości

Netteria.NET

Members
  • Zawartość

    27
  • Rejestracja

  • Ostatnia wizyta

Zawartość dodana przez Netteria.NET

  1. Problem z filtrem

    Wybaczcie z odgrzewam temat ale mimo licznych starań nie udało mi się rozwiązań problemu. https://www.trend-zone.pl/28-paski-i-bransolety-do-zegarkow - klikam w "niedostępne" albo "w magazynie" i znika mi reszta filtrów https://www.trend-zone.pl/20-zegarki-damskie - tu klikam "niedostępne" to filtry zostają ale jak klikam "w magazynie" to znów reszta filtrów znika. Nie mogę rozgryźć tego problemu. Może ktoś spotkał się z czymś takim albo ma jakiś pomysł. Kod przeglądnąłem i nic podejrzanego nie znalazłem.
  2. Problem z filtrem

    Witam Mam problem w filtrze gdy w grupie dostępność wybiorę "na magazynie", "niedostępne" to znikają mi wszystkie inne grupy (kategoria, marka, itd). Poza tym filtr działa ok. Co może być przyczyną?
  3. Witam Chcę zmienić w paginacji linki z ?page=2 na /2/ i tak dalej. W pliku pagination.tpl zrobiłem sobie w prosty sposób {if $page.page===1} href="{$page.url|replace:'/?page=1':'/'}" {else} href="{$page.url|replace:'?page=':''}/" {/if} nie wiem jednak jak zrobić aby te linki działału bo oczywiście teraz dostaję 404. Kombinowałem w .htaccess ale nie to. Pewnie to w kontrolerze trzeba zmienić i wrzucić do overwrite ale nic jakoś na ten temat nie mogę znaleźć Może ktoś coś podpowie. Będę naprawdę wdzięczny.
  4. Witam Chcę zmienić w paginacji linki z ?page=2 na /2/ i tak dalej. W pliku pagination.tpl zrobiłem sobie w prosty sposób {if $page.page===1} href="{$page.url|replace:'/?page=1':'/'}" {else} href="{$page.url|replace:'?page=':''}/" {/if} nie wiem jednak jak zrobić aby te linki działału bo oczywiście teraz dostaję 404. Kombinowałem w .htaccess ale nie to. Pewnie to w kontrolerze trzeba zmienić i wrzucić do overwrite ale nic jakoś na ten temat nie mogę znaleźć Może ktoś coś podpowie. Bedę naprawdę wdzięczny.
  5. Prestashop 1.6.1.23 - problem z koszykiem

    Problem rozwiązany. Zmienna $PS_CATALOG_MODE mimo ustawienia w BO false przybiera true. Dzięki
  6. Witam Mam problem z koszykiem na preście 1.6.1.23. Produkty dodają się do koszyka. Widzę ich ilość przy ikonce. Natomiast po najechaniu nie rozwija się koszyk a co gorsze po kliknięciu nie ładuje zawartości koszyka i całej reszty niezbędnej do zakupu. Próbowałem i na one page checkaut i na krok po kroku. Nie generuje żadnych błędów js. Przynajmniej nic w konsoli nie wyskakuje. W trybie dev nie widzę nic podejrzanego. Sprawdziłem templatkę i jest ok a i na domyślnej presty jest ten sam błąd. Oczywiście wyczyściłem pamięć podręczną. Usunąłem też porzucone koszyki. Wyczyściłem niepotrzebne statystyki itd, z bazy. Może ktoś miał już taki problem i podpowie w czym może być problem pozdrawiam Sławek
  7. Firma Netteria.NET oferuje szeroki zakres usług wsparcia dla sklepów zbudowanych w oparciu o PrestaShop. Oferujemy między innymi: Wsparcie Doradztwo w wyborze rozwiązań eCommerce, serwis sklepów internetowych, (stałe wsparcie techniczne), wsparcie i gwarancje po wykonanym projekcie sklepu. Projektowanie modułów dla prestasop. Projektowanie nowych modułów, według ustaleń, dostosowanych do indywidualych zadań, modernizacja oraz aktualizacja działajacych modułów, moduł - niezależny skrypt. Modyfikacje kodu sklepu. Wszelkie modyfikacje kodu źródłowego skryptu prestashop, modyfikacje kodu szablonu sklepu internetowgo, naprawa sklepów prestashop, naprawa sklepów "po włamaniu", aktualizacja skryptu do wyższej wersji, optymalizacja (SEO) pod wyszukiwarki internetowe, optymalizacja wydajności działania sklepu. Zapraszamy do kontaktu. Chętnie odpowiemy na Twoje pytania na temat modyfikacji, rozszerzeń, wsparcia, oraz naprawy dla sklepów prestashop. Zainteresowanych zapraszam do kontaktu: Prestashop - naprawa i pomoc Oferujemy również kompleksowe wsrożenia sklepów PrestaShop - Budowa sklepów internetowych opartych na PrestaShop
  8. Witam Chciałem zaktualizować prestę 1.6.1.1 do wyższej wersji i dziwna sytuacja - ściągnąłem moduł do uaktualnienia dla tej wersji, wszedłem w moduły, wgraj moduł i po chwili wszystko mi się wywaliło. Aktualnie jak chcę wejść do admina dostaję error 500. Co ciekawe sam sklep działa jak działał. Co to może być? Niestety do logów serwera nie mam dostępu. Jakieś tam są ale nie z błędów PHP i nie mogę ustalić. Będę wdzięczny za podpowiedź. pozdrawiam Sławek
  9. Nie można zapisać produktu PS 1.6.1.20

    Problem rozwiązany. Faktycznie poprzedni programista błędnie zadeklarował zmienną post_max_size i presta dostawała pusty ciąg zamiast wartość. Dlatego posypało się JS.
  10. Przejąłem sklep i jest w nim dość dziwny błąd. Mianowicie w panelu administracyjnym w karcie produktu przede wszystki ciągle kręci się loader na przyciskach "zapisz i zostań" oraz "zapisz". Kombinowałem już cały dzień i szukałem po necie i nie znalazłem rozwiązania. Dotatkowo jak nawet uda mi się uaktywnić tak na wydrę te przyciski to mimo że dostaję komunikat że zamiany zostały zapisane to owe zmiany się nie zapisują. Ponad to w zakładce "zdjecia" i "załączniki" nie pokazują mi się one choć produkt ma je przyporządkowane. Znalazłem błąd JS który pokazuje się przy wczytywaniu strony produktu pod adminem SyntaxError: expected expression, got ',' Dodam że ten błąd występował w weresji 1.6.1.1 i myślałem że może aktualizacja do 1.6.1.20 to rozwiąże ale niestety nic z tego:( Ręce mi opadają. Będę wdzięczny za wszelką podpowiedź i wskazówkę pozdrawiam Sławek
  11. Nie można zapisać produktu PS 1.6.1.20

    No niestety nie ten plik ale myślę że ten problem. To musi się gdzieś dynamicznie generować idąc z kontrolera: $('#file').fileupload({ dataType: 'json', async: false, autoUpload: false, singleFileUploads: true, maxFileSize: , <--- TU WIDAĆ BŁĄD start: function (e) { file_upload_button.start(); $('#file-upload-button').unbind('click'); //Important as we bind it for every elements in add function }, fail: function (e, data) { $('#file-errors').html(data.errorThrown.message).parent().show(); $('#file-files-list').html('').parent().hide(); }, Muszę jeszcze pogrzebać choć łeb mi pęka po całym dniu. Oczywiście jak się uda rozwiązać to napiszę bo może komuś też kiedyś się przyda.
  12. Nie można zapisać produktu PS 1.6.1.20

    Właśnie się dogrzebałem i może to będzie to. W pliku form.tpl w $('#file').fileupload({ ... jest post_max_size i wygląda na to że podaje pustą wartość. I z tego powodu jest taki babol maxFileSize: , co oczywiście powoduje błąd. Wywala więc to zakładkę fotek i załączników i nie kończy XHR więc buttony się kręcą. Oczywiście to kręcenie wyeliminowałem w prosty sposób no ale to nie załatwia sprawy bo nie mam załączników i fotek do produktu w edycji. Zaraz przekoduje i dam znać czy to to:)
  13. Prestashop 1.6.1.1 - error 500 ale tylko a adminie

    Tak wiem. Oczywiście że mam kopie. Bez tego ani rusz:) Jednak problem był trywialny:) Okazało się że zbyt stara wersja PHP jest ustawiona.
  14. Prestashop 1.6.1.1 - error 500 ale tylko a adminie

    Udało mi się wymusić log php przez htacces i mam takie coś [09-Sep-2018 14:11:55 Europe/Warsaw] PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in /modules/autoupgrade/classes/UpgradeTools/Translator.php on line 42 Bardzo rozumiem co z tym błędem zrobić
  15. API prestashop 1.7 błędne dane

    Podatek już wiem jak wyciągnąć w wartości liczbowej: Trzeba się odwołać do id_tax_rules_group to id_tax_rules_group wyciągamy z info o produkcie czyli api/texes/id_grupy To jeszcze tylko obniżkę dla produktu i będzie ok
  16. API prestashop 1.7 błędne dane

    No i właśnie nie jest to takie proste. /api/products/ id zwrca xmla ale jest tam tylko wartość pirce w netto. A nie ma wartości podatku jest jedynie /api/tax_rule_groups/2 a tam znów tekstowa nazwa "PL podatek coś tam (23%)" a do tego trzeba raczej wyciągnąć liczbę czyli 23. Oczywiście można zaryzykować i wyszukać w takim stringu wartości liczbowej ale to raczej mało eleganckie rozwiązanie. A już kwotę (która pewnie też jest procentowa) zniżki to w ogóle nie znalazłem. Grzebie w tym i jak się uda to napiszę ale czarno to widzę. Może ktoś to już robił i coś nam podpowie.
  17. API prestashop 1.7 błędne dane

    Mam dokładnie ten sam problem w wersji 1.7.3 też mi zaciąga jakąś bezsensowną cenę nie wiem czy faktycznie jest tak jak pisze @ircykk że zaciąga cenę netto ale raczej nie bo ja mam dziwne wartości. Na przykład 72.12254346 to raczej nikt takiej ceny netto nie podał. Ale fakt, że u mnie to akurat muszę pobrać ceny po zniżkach i w brutto oczywiście. Ni cholery nie wiem jak to zaciągnąć. Mam price i taką bezsensowną wartość. Jak się uda Aniu rozwiązać to daj znać. Ja też z tym powalczę.
  18. Migracja do Prestashop 1.7

    Odświeżę temat. @saycool - mógłbyś napisać parę słów jak ręcznie przeprowadziłeś tą aktualizację do 1.7? I ogólnie do wszystkich prośba jeśli ktoś robił taką aktualizację to jak to zrobił, na co zwrócić uwagę, jak poszło. Stoję właśnie przed takim wyzwaniem. Z góry dzięki za pomoc i pozdrawiam
  19. problem z slash na końcu adresu url i htaccess

    Tak, w htaccess to faktycznie nie ma co specjalnie kombinować. Czyli dobrze wykombinowałem?:) Czasem po prostu mam wrażenie że potraktuję coś zbyt topornie ale może faktycznie przesadzam. W końcu w tym miejscu mam zmienną która mnie informuje że jest to do producentów więc problemu z identyfikacją nie ma w warunku i tylko tam doda ukośnik. Oczywiście wszystko w override.
  20. Witam Mam taki problem. Zainstalowałem sobie do testów na serwerze NAS prestashop 1.7.3. Jest to dziewicza instalka zatem nic tam namieszane na pewno nie jest. Domyślnie adres url do marek jest sklep/brand a ja chcę zrobić aby wczytywało marki też dla adresu sklep/brand/ Zacząłem kombinować wymuszenie w .htaccess ale ciągle nie było żadnego efektu (oczywiście czyściłem pamięć podręczną). W końcu zastanowiłem się czy aby na pewno w tym pliku grzebię co trzeba (oczywiście grzebałem w .htaccess w głównym katalogu) i na próbę wszystko z niego wywaliłem. I z zdziwieniem stwierdziłem że sklep sobie dalej działa jak działał (a chyba nie powinien bez tego pliku). Co może być powodem? I jak wymusić ten ukośnik na końcu?
  21. problem z slash na końcu adresu url i htaccess

    Zmieniłem w klasie Dispatcher w metodzie loadRoutes url_rewrite na brands/ i działa. Ale mam wrażenie, że to nie jest najbardziej eleganckie rozwiązanie. Oczywiście nadpiszę tą klasę żeby nie było problemów przy aktualizacji presty. Ale moze ktoś zna lepsze rozwiązanie?
  22. problem z slash na końcu adresu url i htaccess

    Dzięki za odpowiedź. Ale to nie rozumiem trochę. Nie mogę wymusić w htaccess aby działał link z ukośnikiem na końcu? W sumie to chodzi tylko o prostą rzecz aby działał adres w formacie adres_sklepu/barnd/ bo teraz daje mi 404 a oczywiście adres_sklepu/brand działa bez problemu. I w sumie chcę doprowadzić do sytuacji odwrotnej. Ale jakoś zmiany w htaccess kompletnie nie przynoszą rezultatu. jeszcze raz dzięki za pomoc pozdrawiam Sławek
  23. Filtry i problem z paginacją - PS 1.6

    Tak, dokładnie źle generował się link. Dzięki za pomoc.
  24. Witam Mam taki sklep który dostałem w spadku więc tak naprawdę nie wiem co tam wcześniej kto rzeźbił. Aktualnie mam taki problem że przy użyciu filtrów paginacja mi szaleje i dostaję z kontrolera 404. https://strefasukienek.pl/12-sukienki#/kolor-czarny i mam dwie strony wyników. Na dole w paginacji kliknę aby przerzuciło na drugą stronę i dostaję 404. Oczywiście tak jest dla każdej kombinacji gdy wychodzi więcej niż jedna strona Wersja presty to 1.6.1.15 Siedzę od rana, grypa mnie rozwala, i ni cholery nie wiem co to może być. Może ktoś coś podpowie. Będę bardzo wdzięczny. z góry dzięki Sławek
  25. Filtry i problem z paginacją - PS 1.6

    Problem rozwiązany. Dziękuję wszystkim za zainteresowanie. Jakby ktoś miał taki problem w przyszłości to warto zerknąć w pliku Link.php - u mnie poprzedni programista namieszał w metodzie generowania linku:( No ale udało się to wyśledzić metodą porównawczą i z innym działającym sklepem jaki mam pod opieką. pozdrawiam Sławek
×