Skocz do zawartości

tomas82

Members
  • Zawartość

    21
  • Rejestracja

  • Ostatnia wizyta

Zawartość dodana przez tomas82

  1. Witam, Sklep migrował od 1.3 do 1.4. Następnie do 1.5 i potem do 1.6.1.14. Dostajemy następujący błąd classes/tax/TaxCalculator.php on line 124 Notice: Undefined offset:4 Pozdrawiam Łukasz
  2. Witam :) Aktualizuję sklep z 1.3 na 1.4 i potem do 1.6.15. Sklep zaktualizował się do wersji 1.4 i tu zaczęły mi się schody. Dostaję taki komunikat "Table 'ltomasz_presta.ps_tax_zone' doesn't exist ''. Wchodząc do bazy danych nie ma tej tabeli. Czy można ją stworzyć , nadpisać , jeśli tak to w jaki sposób? I dlaczego nie ma tej tabeli ? Backup bazy dostałem od admina serwera. pozdrawiam łuki
  3. 1-click upgrade prestashop1.6.1.21

    Cześć W panelu narzędzia mamy opcję 1-click upgrade . Klikasz i po prawej stronie masz mniej opcji , bądź tryb experta. Wybierasz więcej opcji, tryb experta i tam wybierasz kanał jako ścieżka lokalna , następnie ściągasz starą wersję i rozpakowujesz do /admin/autoupgrade/latest/ i przypisać musisz wersję do jakiej migrujesz . Sam jestem początkujący , może ktoś bardziej doświadczony coś doda. Pozdrawiam
  4. Cześć Mam kilka błędów podczas aktualizacji z 1.3 do 1.6 . Na początku migrowałem z 1.3 na .1.4 ręcznie, natomiast dalej do 1.5 i 1.6.21 za pomocą 1-click . Tu napotkałem kilka błędów (wszystko testuję lokalnie i system to ubuntu) : Warning: openssl_decrypt(): IV passed is only 7 bytes long, cipher expects an IV of precisely 16 bytes, padding with \0 in /var/www/html/prestashop1/classes/Rijndael.php on line 91 Fatal error: Uncaught --> Smarty: Unable to load template file '/var/www/html/prestashop1/themes/default-bootstrap/header.tpl' <-- thrown in /var/www/html/prestashop1/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 129 Pozdrawiam Ps. Dzięki za odpowiedź Łukasz
  5. Aktualizacja z 1.3 do 1.4

    Cześć, problem rozwiązany,admina nazwałem tak jak w starym sklepie, u mnie nazywał się back-office. Nie za bardzo rozumiem dlaczego
  6. Witam, Po aktualizacji sklepu na localhoscie z 1.3 do 1.4 mam problem z zalogowaniem się do panelu admina. Sklep chodzi bez problemu, wszystko jest (zdjęcia, kategorie itd.). Usunięte pliki: install, readme i changelog. Admin zmieniony na admin444. Podczas wywołania logowania do panelu administracyjnego włącza się protokół https i napis: Unable to connect Firefox can't establish a connection to the server at 127.0.0.1. Jak się tego pozbyć? Gdzie tkwi problem? Jak zalogować się do panelu administratora? Podobny komunikat wyświetla się podczas próby zalogowania się jako klient do sklepu. pozdrawiam
  7. Aktualizacja z 1.3 do 1.4

    Cześć, Ustawiłem w tabeli PS_SHOP_DOMEIN localhost i PS_SHOP_DOMEIN_SSL również localhost i można się rejestrować i widać koszyk, natomiast dalej nie mogę dostać się do admina.Pracuję na Ubuntu( uczę się go) . PS_REWRITING_SETTINGS = 0 i to również nie pomogło. Pozdro
  8. Aktualizacja z 1.3 do 1.4

    Cześć Dzięki za odpowiedź, w bazie danych ps_ssl_enabled ustawiałem już na 0 .Nie wiem gdzie mam to zrobić w bazie. Efekt jest ten sam. Pozdrawiam
  9. chat

    Cześć Staram się dokonczyć instalację modułu chat. Nie wiem gdzie wkleić kod First, activate the Zendesk Chat widget on your website by copying and pasting the following code between <head> and </head> tags of your site's HTML file: . Czy mam t wkleić tam gdzie themes i w pliku header? Pozdrawiam
  10. .htaccess

    Cześć Wszystko gra , pomogło włączenie mod_revrite. Dziękiii
  11. .htaccess

    Witam Od tygodnia po godzinach staram rozwiązać się temat. Bigdump ruszył i wielkie dzięki dla Ircykka . Mam problem z .htaccess . Tworzę pusty plik w głównym katalogu nazywając go .htaccess. Przy próbie wygenerowania dostaje taki komunikat ze strony 'The requested URL /public_html/x.php was not found on this server'. Dodatkowy problem to brak znaków polskich. Bazę eksportowałem za pomocą metody porównań utf8.bin. // Connection character set should be the same as the dump file character set (utf8, latin1, cp1251, koi8r etc.) // See http://dev.mysql.com/doc/refman/5.0/en/charset-charsets.html for the full list $db_connection_charset = ''; Czy w bigdumpie powinienem w connection wpisać utf8? A może, to brak znaków polskich i dlatego nie mogę wygenerować .htaccess. Pozdrawiam Łukasz
  12. Bigdump

    Zrobione, wielkie dzięki za pomoc. Bigdump fajny programik.
  13. Bigdump

    Witam Postawiłem na serwer Vertrigo ver 2.33 ( oczywiście czytając forum, polecany do presty i pracy dla początkujących). Serwer sprawuje się wyśmienicie. Jednak mam problem z Bigdumpem. Wersja bigdumpa to 0.32 .Podczas odpalania wyskakuje mi taki komunikat " BigDump: Staggered MySQL Dump Importer v0.32b Processing file: ltomasz_sklep.sql Starting from line: 12004 Error at the line 13787: INSERT INTO `ps_address` VALUES(496, 14, 0, 469, 0, 0, 'address1' , MySQL: Data too long for column 'company' at row 1 Nie jestem znawcą , ale wydaje mi się , że jest za długa nazwa. Co z tym zrobić?
  14. .htaccess

    problem z polskimi znakami rozwiązany , htaccess nie.
  15. Przeniesienie sklepu na localhost

    Niestety tak to wygląda .Może coś nie tak z uprawnieniami do plików ?
  16. Witam Coś poszło nie tak , baza danych wgrana , pliki również ,ale brak templates ?Logowanie do back-office działa.
  17. Przeniesienie sklepu na localhost

    Cześć Dzięki za pomoc , temat jest mi znany , przeszukałem forum . U mnie natomiast nie ma tabeli ps_shop_url , natomiast jest base url i tam wpisałem ścieżkę dostępu . Jest lepiej ale nie idealnie , brak kategorii , zdjęć , na końcu jest taki wpis "Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in D:\WebServ\httpd-users\sklep\classes\Page.php on line 44" pozdrawiam
  18. Kopia bazy danych

    Dziękuję
  19. Cześć Dawno już tu nie zaglądałem , tak więc na wstępie cześć. Mam problem ze zrobieniem bazy danych z pozycji sklepu. Zakladam , że baza jest duża i mam problem ze ściągnięciem jej, bądź operator ma wyznaczone godziny do zrobienia tego (linux.pl). Pytanie jak to zrobić. Pozdrawiam Łukasz
  20. Witam Mam Prestę w wersji 1.3.6.0 . Presta wcześniej była na serwerze nazwa.pl . Teraz została przeniesiona na linux.pl . Przeniesiona została domena . Zainstalowany został również certyfikat .Certyfikat również został przeniesiony na serwer linuxa . Linux wymagał dodatkowego IP do certyfikatu i to również zostało zrobione , Od tego czasu mam problem z prestą . Zależy mi na bezpiecznym logowaniu i rejestracji i stąd certyfikat . Aby nie było tak dobrze strona zaczeła mi sie rozjeżdzać . Jeżeli klient będzie logował się przez https://www.twojzwierzyniec.pl to przeglądarka chrom nie pokazuje kategorii i nakładają się banery . Natomiast jak zmieni się adres na https://twojzwierzyniec.pl to banery są ok ale znowóż jest brak kategorii. Strona wyświetlana jest prawidłowo na http:// twojzwierzyniec.pl . Próbowałem zmodyfikować strone poprzez przekierowanie https na http . Jedna nic mi się nie udało Mój plik htaccess # .htaccess automaticaly generated by PrestaShop e-commerce open-source solution # http://www.prestashop.com - http://www.prestashop.com/forums # URL rewriting module activation RewriteEngine on RewriteCond %{HTTP_HOST} ^https://twojzwierzyniec.pl RewriteRule ^(.*)$ http://twojzwierzyniec.pl/$1 [R=301,L] [/size] # URL rewriting rules RewriteRule ^([a-z0-9]+)\-([a-z0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2$3.jpg [QSA,L,E] RewriteRule ^([0-9]+)\-([0-9]+)/([_a-zA-Z0-9-]*)\.jpg$ /img/p/$1-$2.jpg [QSA,L,E] RewriteRule ^([0-9]+)(\-[_a-zA-Z0-9-]*)/([_a-zA-Z0-9-]*)\.jpg$ /img/c/$1$2.jpg [QSA,L,E] RewriteRule ^lang-([a-z]{2})/([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$3&isolang=$1$5 [QSA,L,E] RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2&isolang=$1$4 [QSA,L,E] RewriteRule ^lang-([a-z]{2})/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$2&isolang=$1 [QSA,L,E] RewriteRule ^([a-zA-Z0-9-]*)/([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$2$4 [QSA,L,E] RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)\.html(.*)$ /product.php?id_product=$1$3 [QSA,L,E] RewriteRule ^([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /category.php?id_category=$1 [QSA,L,E] RewriteRule ^content/([0-9]+)\-([a-zA-Z0-9-]*)(.*)$ /cms.php?id_cms=$1 [QSA,L,E] RewriteRule ^([0-9]+)__([a-zA-Z0-9-]*)(.*)$ /supplier.php?id_supplier=$1$3 [QSA,L,E] RewriteRule ^([0-9]+)_([a-zA-Z0-9-]*)(.*)$ /manufacturer.php?id_manufacturer=$1$3 [QSA,L,E] RewriteRule ^lang-([a-z]{2})/(.*)$ /$2?isolang=$1 [QSA,L,E] # Catch 404 errors ErrorDocument 404 /404.php php_value max_execution_time 259200 Pozdrawiam Łukasz
  21. Presta shop problem z https

    Witam Czyli co powinienem zrobić , wcześniej na innym serwerze na nazwa.pl nie miałem tego problemu. Zmodyfikowane zostało przekierowanie i to wystarczyło. Dzięki Pozdro
×